Harley Davidson V-Rod Forum banner

1 - 12 of 12 Posts

·
Sua Sponte
Joined
·
1,560 Posts
Discussion Starter #1
Anyone in here have Z Bars on their bikes?? I just ordered a set from V-Mod and wanted some insight.
 

·
Dilligaf
Joined
·
5,393 Posts
I have a set I got from debrix on ebay, I love em. Pics are in my gallery.
 

·
Billy
Joined
·
3,464 Posts
I've gotta Chica mini Z-bzrs. You can see them in my gallery. My favorite mod to date.
 

·
Sanctimonious
Joined
·
44,118 Posts
Vmod Zbars I Love them, run the cables and such as I did or else the bunch (unless your going to do the 4 day task of running things INSIDE the bars, good luck with that.
 

·
Still here, sort of
Joined
·
17,374 Posts
luxlamf said:
Vmod Zbars I Love them, run the cables and such as I did or else the bunch (unless your going to do the 4 day task of running things INSIDE the bars, good luck with that.
Not kissin' up to Lux...no need...those are the sweetest looking!:dance:
 

·
V's and Z's
Joined
·
4,093 Posts
I got mine on ebay. They are called "Z bars", but aren't shaped quite like a "Z". These would be easier for running wires inside, though I didn't...

 

·
Banned
Joined
·
4,397 Posts
do they offer them in different sweeps?
 

·
V's and Z's
Joined
·
4,093 Posts

·
Sua Sponte
Joined
·
1,560 Posts
Discussion Starter #10
luxlamf said:
Vmod Zbars I Love them, run the cables and such as I did or else the bunch (unless your going to do the 4 day task of running things INSIDE the bars, good luck with that.
Those look nice. How long did it take you to install them?? Was it a fairly simple procedure? And what do you mean to run the cables as you did? What is the trick??
 

·
Sanctimonious
Joined
·
44,118 Posts
metallica0099 said:
Those look nice. How long did it take you to install them?? Was it a fairly simple procedure? And what do you mean to run the cables as you did? What is the trick??
It took me about 25 minutes, You don't have to bleed the clutch or brake. I ran the cables a bit differently when I did it and it caused some bunching up so I had to reroute them again.
 

·
Sua Sponte
Joined
·
1,560 Posts
Discussion Starter #12
luxlamf said:
It took me about 25 minutes, You don't have to bleed the clutch or brake. I ran the cables a bit differently when I did it and it caused some bunching up so I had to reroute them again.
Aaaah, I see. Sounds like a pretty easy mod to do.
 
1 - 12 of 12 Posts
Top