Harley Davidson V-Rod Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,500 Posts
Discussion Starter #1
we have an x here which is fitted with stage two cams and vnh pipe[not the comp one].its has been tuned with the sert.it has a miss fire problem when quick accel is applied yet also at irregular times also.its not consistent at all.the plugs are new.the iac motor is new.the coils are new.new battery too.the fuel pump sock looked to be dirty at the pick up yet cleaned up ok.it feels like a fuel problem more than ignition.some days it runs fine then it will play up.are there any ideas anyone has to offer on this one ? has anyone had problems with the fuel pressure regulator as im suspicious of that.
 

·
Registered
Joined
·
2,103 Posts
i have seen symptoms like you describe from the fuel inlet sock colapsing against the fuel pump inlet.. the fuel pressure check when the problems occurs will tell you if it is fuel pressure related..
 

·
Loud and Proud
Joined
·
628 Posts
I just replaced a stock fuel pump that was giving me problems.
When the engine was at around 2800 -3000 RPM I would get a occasional miss fire for 1 second. This problem has been happening for the last 2 years. Finally the bike did not start. The fuel pump was not turning on. To make a long story short the old pump has some sort of intermittent electrical connection internally going on.

I replaced the pump, and the bike runs better now. No miss fires and the acceleration is much smoother and responsive.

The one thing I did differently than stock is I soldered the wire leads directly to the pump terminals for a solid connection.
 

·
Registered
Joined
·
2,500 Posts
Discussion Starter #6
we replaced the pickup sock and filter too yet the problem persisted.it started throwing the po122 code so we tested the tps sensor for continunity and it seemed ok yet we renewed that and now its running great.
 
1 - 6 of 6 Posts
Top