Harley Davidson V-Rod Forum banner

1 - 10 of 10 Posts

·
Registered Used
Joined
·
342 Posts
Discussion Starter #1
Hi
Anyone else have this problem?
Sometimes - usually when its dark and I have a girl on the back - embarasing, the blue headlight on the instrument cluster stays on but my headlight stays off. If I sit there for 2 or 3 minutes it will come on.
Any ideas?

Cheers
 

·
Registered
Joined
·
5,869 Posts
The blue indicator is high beams - what happens if you switch to low beams? Same thing?
 

·
Sanctimonious
Joined
·
44,118 Posts
used to happen to me when I turned Left, found the wire to the bulb frayed.
 

·
Registered Used
Joined
·
342 Posts
Discussion Starter #4
Even if I switch from low beam to high beam and back the headlight still stays off and the high beam indicator stays on. Wierd.
 

·
Premium Member
Joined
·
11,329 Posts
The blue light being on all the time is a indicator you have a problem. You probably have a loose connection somewhere. Check the back of the headlight. One or two bulbs/connections depending on the bike. Check fuses, light bulbs, wiring for loose/broken connections.
 

·
WHATEVER
Joined
·
3,739 Posts
you have a short in the left handle controls, trace the wires back to where they conect in the left side cover and you will find it!
 

·
Friend of Max.
Joined
·
21,719 Posts
DTHDOC said:
you have a short in the left handle controls, trace the wires back to where they conect in the left side cover and you will find it!
:stupid:

That's the only way you can have the malfunction described.
 

·
1130cc Ninja
Joined
·
3,972 Posts
definitely sounds like a short.. start tracing wires and look very closely for some cuts on your wiring
 

·
Registered Used
Joined
·
342 Posts
Discussion Starter #9
Hey thanks for all the help guys.
Better start tracing then.
Might even drop the handlebars back a few inches at the same time.
Cheers
 
1 - 10 of 10 Posts
Top