Harley Davidson V-Rod Forum banner

1 - 13 of 13 Posts

·
MODOHOLIC ANONYMOUS
Joined
·
7,448 Posts
Discussion Starter · #1 ·
 

·
Killer Service Inc.
Joined
·
8,946 Posts
:notworth::notworth::notworth:
 

·
MODOHOLIC ANONYMOUS
Joined
·
7,448 Posts
Discussion Starter · #7 ·
Extreme machine.. Thanks guys
 

·
Dean
Joined
·
775 Posts
Looks good. Is the rear brake on the other side with the pulley?
 

·
MODOHOLIC ANONYMOUS
Joined
·
7,448 Posts
Discussion Starter · #9 ·
Lol I was wondering if anyone would catch that. I haven't mounted the rotor yet. It'll be on this side until the day I can get ohiovrod to mount it all on the other side
 

·
MODOHOLIC ANONYMOUS
Joined
·
7,448 Posts
Discussion Starter · #10 ·
 

·
Premium Member
Joined
·
10,801 Posts
nice!
 

·
MODOHOLIC ANONYMOUS
Joined
·
7,448 Posts
Discussion Starter · #13 ·
So what was the issue?
long story but... there really wasn't a issue.. when i ordered the wheels i told xtreme that i had a 05A but needed the wheel/pulley set up for a 06SE... fast forward.. when the wheels arrived the pulley was wide not narrow.. that should've been a clue.. i sent the pulley back to have it machined down, got the 06SE spacers and tried to mount it. things just wouldn't line up. i took it out to Covingtons (bought the wheels from them) to see what they thought. tech put the stock 05 spacers in and it all lined up right. so i guess xtreme cut it all for a 05A.. biggest clue was the way the belt lined up on the offset pulley..lol.. problem is remedied now.. so if anyone is doing a 240 swap, just call xtreme and have them make a 8.5 with a narrow pulley and 05A specs. run your stock front pulley and you're good
 
1 - 13 of 13 Posts
Top