Harley Davidson V-Rod Forum banner
1 - 6 of 6 Posts

·
The Hawk
Joined
·
3,920 Posts
I don't think mine is a walbro pump. It has been a while, but I thought mine was an Edlebrock pump, could be made by walbro but not sure. It is still in the bike, running with the big bore setup.

Mike
 

·
I'm Bored
Joined
·
1,741 Posts
Discussion Starter · #3 ·
i've got the walbro, i actually ordered it direct from them last year when i bought the turbo from Sam. my problem is that the plastic flange came off the high pressure outlet so the hose doesn't want to stay on. i sent Richard an email and he said the part number should be on the pump so i'll just have to pull it and see. i sent Sam a message but he doesn't seem to get on here much anymore and i lost his number.
 

·
Banned
Joined
·
12,582 Posts
sgtrage said:
i've got the walbro, i actually ordered it direct from them last year when i bought the turbo from Sam. my problem is that the plastic flange came off the high pressure outlet so the hose doesn't want to stay on. i sent Richard an email and he said the part number should be on the pump so i'll just have to pull it and see. i sent Sam a message but he doesn't seem to get on here much anymore and i lost his number.
just call him on his cell:wazzup: ? or e-mail his TTUSA address;)

P.S 255- GLPHR Mustang pump.:kaz:
 

·
Premium Member
Joined
·
5,721 Posts
Super Kaz said:
just call him on his cell:wazzup: ? or e-mail his TTUSA address;)

P.S 255- GLPHR Mustang pump.:kaz:
I think he's talking about VotRod (Sam). That's who he bought turbo kit from last year.
 

·
Banned
Joined
·
12,582 Posts
bproulxvrod said:
I think he's talking about VotRod (Sam). That's who he bought turbo kit from last year.
oh my BAD Never Mind Sorry:hidesbeh: .
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top