Harley Davidson V-Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter · #1 ·
So pissed right now. Beyond pissed. My TSM for front signals fried but rear tail light and signals was fine as they have their own module. Just installed new Front TSM. front signals flash for a second and go out. Rear tail light stays solid on bright like when braking. Now I have now rear turn signal at all. Probabaly done reset sequence but damned if I know. The support at badlands sent me the reset sequence for fronts but that didn’t work and the green arrow indicators on dash don’t light up at all. One thing is I have aftermarket LED mirrors w signals installed. Dunno if that’s part of issue ? I hooked up an OEM mirror (other OEM was damaged when bike knocked over) and it did same thing as far as one second flash and then goes out. Insult to injury I just tried booking up an led light from aamazon and only low beam will work. I had done FBJ mod and wonder if that is part of issue on headlight. Any HD electrical experts out there have suggestions. ?
 

·
Registered
Joined
·
1,989 Posts
My only suggestion is to check for a short. Probably easiest way is to unhook all of the signals at the molex plug and plug them in one by one and see when they stop working. If you can't get any of them to work the first hookup it has to be something either in the module or further down from the molex plug.

You should be able to hook your lights up straight to the battery and have them turn on. One thing I would say though is that if you suspect a short put a fuse between the battery and the light or you could make fire.

-Keith
 

·
Premium Member
Joined
·
6,248 Posts
...
... My TSM for front signals fried but rear tail light and signals was fine as they have their own module. Just installed new Front TSM. front signals flash for a second and go out. Rear tail light stays solid on bright like when braking. Now I have now rear turn signal at all. Probabaly done reset sequence but damned if I know. The support at badlands sent me the reset sequence for fronts but that didn’t work and the green arrow indicators on dash don’t light up at all. One thing is I have aftermarket LED mirrors w signals installed. Dunno if that’s part of issue ? I hooked up an OEM mirror (other OEM was damaged when bike knocked over) and it did same thing as far as one second flash and then goes out. Insult to injury I just tried booking up an led light from aamazon and only low beam will work. I had done FBJ mod and wonder if that is part of issue on headlight. Any HD electrical experts out there have suggestions. ?
What do you mean by "rear tail light and signals was fine as they have their own module"?

Where did these separate front and rear modules come from?

The OEM TSM/TSSM is used for both front and rear turn signals.

Also, mixing turn signal issues with head light testing just confuses the discussion.
 

·
Laid back grump
Joined
·
30 Posts
Please don't just connect your LEDs to a 12VDC source. LEDs require a voltage regulator/current limiter, and the front and rear TSM modules perform that function. The central TSM performs the self-cancelling function based upon lean angle and communicates with the instrument cluster over what looks like a CAN bus.

Did you compare the resistance of the OE turn signals with the aftermarket? Also, do you have the wiring diagrams for your model year?
 

·
Tie One On
Joined
·
1,647 Posts
So pissed right now. Beyond pissed. My TSM for front signals fried but rear tail light and signals was fine as they have their own module. Just installed new Front TSM. front signals flash for a second and go out. Rear tail light stays solid on bright like when braking. Now I have now rear turn signal at all. Probabaly done reset sequence but damned if I know. The support at badlands sent me the reset sequence for fronts but that didn’t work and the green arrow indicators on dash don’t light up at all. One thing is I have aftermarket LED mirrors w signals installed. Dunno if that’s part of issue ? I hooked up an OEM mirror (other OEM was damaged when bike knocked over) and it did same thing as far as one second flash and then goes out. Insult to injury I just tried booking up an led light from aamazon and only low beam will work. I had done FBJ mod and wonder if that is part of issue on headlight. Any HD electrical experts out there have suggestions. ?
some led headlights are wired opposite. check that. you might want to check the led wiring within the light if at all possible to verify shortouts there.
do they work if connected directly to a battery. you can even jump them with a 9 volt to see
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top