Harley Davidson V-Rod Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
03' VRSCA/ 15K
I just went out to my bike which I left outside overnight at my cousin's house, and when I went to leave, I geared into first..went to the stop sign, an noticed that my gear shifter did not pop back into ready position to shift up into second. It popped down into first and just stayed there, flat. So I pulled over, checked it out, and low and behold, my gear shifter isn't working. So I cut it off and then cut it back on, and tried to give it a slight up into neutral....it went up and just stayed there. Straight passed neutral. It popped into gear, but it wasn't 2nd, because it clucked and stalled out.
Any ideas about what happened? I believe I may have been sabotaged even.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
Gear shift just stopped working tonite.

03' VRSCA/ 15K
I just went out to my bike which I left outside overnight at my cousin's house, and when I went to leave, I geared into first..went to the stop sign, an noticed that my gear shifter did not pop back into ready position to shift up into second. It popped down into first and just stayed there, flat. So I pulled over, checked it out, and low and behold, my gear shifter isn't working. So I cut it off and then cut it back on, and tried to give it a slight up into neutral....it went up and just stayed there. Straight passed neutral. It popped into gear, but it wasn't 2nd, because it clucked and stalled out.
Any ideas about what happened? I believe I may have been sabotaged even.
 

·
Registered
Joined
·
1,306 Posts
03' VRSCA/ 15K
I just went out to my bike which I left outside overnight at my cousin's house, and when I went to leave, I geared into first..went to the stop sign, an noticed that my gear shifter did not pop back into ready position to shift up into second. It popped down into first and just stayed there, flat. So I pulled over, checked it out, and low and behold, my gear shifter isn't working. So I cut it off and then cut it back on, and tried to give it a slight up into neutral....it went up and just stayed there. Straight passed neutral. It popped into gear, but it wasn't 2nd, because it clucked and stalled out.
Any ideas about what happened? I believe I may have been sabotaged even.
Replied to your other post
 
1 - 3 of 3 Posts
Top