Harley Davidson V-Rod Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Problem, just had my 2010 v-rod muscle tuned today. According to the chart 110.21 H.P. Torque 76.83. However, before the tune she was getting 19.3 miles to the gallon @ 65 miles per hour no back fires when throttling down ect.

Now, she is a new beast lots of power. But she is only getting 18.25 miles to the gallon. H.D. website says 34 city and 42 highway.

I put on a K&N filter, Screaming Eagle Super Tuner PRO and TAB performance exhaust. Anyone have any ideas??

Thanks,

Ray
 

·
Registered
Joined
·
251 Posts
The F's seem to be all over the map in terms of fueling and mpg...I was getting in the mid 20's combined mpg but it seems to be getting better as I put more mileage on the motor. As we are running the same set up...send me a copy of your map and I'll compare it to mine.
 

·
Registered
Joined
·
251 Posts
any update NASCAR???
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #5 ·
Sorry about not getting back to you sooner. I will have to call them tomorrow, my dealer fixed the problem but found another. Apparently, my trans is not shifting correctly. They will have to tear her down and find the problem. Good thing its under warranty, my tech said HD did not give them any problems other than fix it!
 

·
Registered
Joined
·
251 Posts
Hopefully, your mpg's will be closer to the norm now...make sure you get your map from the dealer...always good insurance. If you get it I'd still like to take a look.
 

·
Cajun-VRSCF
Joined
·
263 Posts
My bike was the same but I tuned the crusing rpm/throttle positions for better fuel milage and after playing around for a while I get 160 miles on a tank which is about 34mpg.
 

·
Registered
Joined
·
251 Posts
Cajun, I am running your map but I am getting a lot of decel pop but, fuel mileage seems to be good. Mine is still under 1k mi and economy seems to get better everyday...
 

·
Registered
Joined
·
9 Posts
I got 180 to a tank when it was new then after about 15k that dropped to about 160 and its held there ever since....I just turned 60,000 miles last Friday....its all stock aside from a k&n air filter. I just put ngk plugs in it...and I don't know if its all in my head. but it really seemed to like those.
 
1 - 9 of 9 Posts
Top