Harley Davidson V-Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
I have two issues after a recent repair service...

1. My fuel gauge was not reading correctly.. They supposedly fixed it.. it still does the same thing.

2. I had my instrument cluster replaced because the original had a dead bug in rolling around at the bottom of the speedo.. which was annoying as heck. Bug somehow got in at the factory.. it had been there since the bike was new. -- Anyway, the new instrument cluster is an '04 (bike is '03) so speedo goes to 150, but my milage is not correct now.. I brought it in with about 6020, and they reset the newone to about 5400.

When I bring the bike back to have the fuel gauge fixed (again) Should I care about the milage thing and ask them to fix it?
 

·
Riding around
Joined
·
7,736 Posts
I don't think the mileage matters much on the speedo, but I'd sure make them fix the fuel gauge thing this time...
 

·
Registered
Joined
·
47 Posts
That’s exactly what the dealership is going to do with my bike. They said the reason the fuel gauge is not working is because of the cluster. They have put in an order for another one and I’m waiting for it to be delivered. I find that strange that you had a bug rolling around in the cluster because I had a little insect in mine too. It bugged the hell out of me…no pun intended. I’m glad that they are replacing it but, if this is not going to repair the problem then I definitely am bringing it back. I had to have anything not working correctly on any of my vehicles. I have been just using the odometer to judge the mileage but, when you’re doing a whole bunch of WOT runs I’m sure the gas mileage will not be too consistent. On a $18K bike you should expect that everything on it work :boobs:
 

·
Riding around
Joined
·
7,736 Posts
The glass face piece has fallen in on my gauges now, so I could definitely pick up a bug. Hopefully, it just needs to be snapped back in.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #5 ·
Val said:
The glass face piece has fallen in on my gauges now, so I could definitely pick up a bug. Hopefully, it just needs to be snapped back in.
There's a thread in the "HOW TO" by Max about how to remove the glass plate.

If yours has a problem and your out of warranty, I would remove it and put it back together the right way. If the glass is out of place, you might get water in there.. then you've got problems
 
1 - 5 of 5 Posts
Top