Harley Davidson V-Rod Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,my 2012 vrod stall at idle the bike will only start if i give throttle as soon as i let go of the gas it stall.

I recently remove my exhaust pipe to ceramic coat them while they where out for painting i’ve replace my front brake pads but didn’t have my fob on me. When i put back the wheel i did my code with the flasher so the alarm wouldn’t go off.

The next week got my exhaust pipe back, put everything together,the bike wouldn’t start (probably because i have drain The battery when i didn’t have my fob), so i’ve boosted the bike with my booster pack ( probably not the best idea) at that point the bike would start but only with throttle and as soon i let go of the gas it stalls.

Since then i have installed a new battery still doesnt work . A week before all of this ( after winter ) i went for a ride in town the bike was fine . I need your help thanks in advance
 

·
Registered
Joined
·
5,229 Posts
And the bike give me no code
Sounds like an issue with the IAC motor as it controls the amount of air needed for idle rpms. It's that little black thing in between the two throttle bodies. If it is too closed, then by opening up the throttle a bit with the grip enough air gets in to keep it running. They don't always throw a code. Port might be blocked or the IAC is defective. Inspect the port hole and clean if dirty as a first step. Can you hear it moving in and out with turning key on and off? It can be heard better when key is turned off as the pintle parks itself to the start point. Do not attempt to remove it unless you heat gun the screws first. Snapping a screw off will ruin your day.
Ron
 
1 - 3 of 3 Posts
Top