Harley Davidson V-Rod Forum banner
1 - 10 of 10 Posts

·
Color me Gone
Joined
·
27,333 Posts
Discussion Starter · #1 ·
Don't be alarmed if you get any errors this morning. I am working on a new .htaccess file to avoid attachments being hotlinked to other sites and may cause errors from time to time while I test it.


Max
 

·
Color me Gone
Joined
·
27,333 Posts
Discussion Starter · #2 ·
Ok you can take a break now. I'm done throwing code at this morning. I still can not get the code to work just the way I want but I'm sure there is a way to do it.

Max
 

·
Color me Gone
Joined
·
27,333 Posts
Discussion Starter · #3 ·
Ok you network people, this turned out be my final code. Does anyone see any errors that might get me down the line. It seems to do the trick right now.

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://66.17.131.140 [NC]
RewriteCond %{HTTP_REFERER} !^http://v-rodforums.com [NC]
RewriteCond %{HTTP_REFERER} !^http://www.v-rodforums.com [NC]
RewriteRule .*\.(jpg|gif|bmp|pdf|zip|JPG)$ http://www.v-rodforums.com [R]



RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://v-rodforums.com [NC]
RewriteCond %{HTTP_REFERER} !^http://www.v-rodforums.com [NC]
RewriteCond %{HTTP_REFERER} !^http://66.17.131.140 [NC]
RewriteRule avatar.php [F]


RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://v-rodforums.com [NC]
RewriteCond %{HTTP_REFERER} !^http://www.v-rodforums.com [NC]
RewriteCond %{HTTP_REFERER} !^http://66.17.131.140 [NC]
RewriteRule attachment.php [F]


deny from 204.27.196.105
 

·
SNAFU
Joined
·
13,094 Posts
Looks good to this untrained eye. The only cleanup I can see would be to order the referral links all the same and, based on the order they are interrogated put the www.v-rodforums.com first to minimize processing time since that's where most of the board users link from. (trivial, I know) :diablo:
 

·
Color me Gone
Joined
·
27,333 Posts
Discussion Starter · #5 ·
I'll do that to clean it up a little.

Max
 

·
Color me Gone
Joined
·
27,333 Posts
Discussion Starter · #6 ·
As some may have noticed I have been moving a few things around tonight, I apologize if the moving caused any errors. I wanted to move the who's online and log in near the top of the forum . It just seems natural at the top for me.

Max
 

·
I love my V!!!
Joined
·
311 Posts
Hey MAx,

I know you are hard at work improving the site so I have a question. :notworthy

Maybe I am doing something wrong but I have to set the time a GMT +1 to see the correct time for me. I am in NY and the setting should be -5 GMT.

I also noticed this on the VTF forum so I don't know if I'm doing something wrong or maybe a default setting on the scripts.

Thanks
 

·
Color me Gone
Joined
·
27,333 Posts
Discussion Starter · #10 ·
DrewBoy, what you describe is the result of a lazy administrator of the site, wait that would be me. You are correct, it is in the config and I did not notice it until we already had 50 members (actually when mjw930 PMed me about it) and at that point I decided to leave it so everyone would not have to change again.


Max
 
1 - 10 of 10 Posts
Top