Harley Davidson V-Rod Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
doesn't return after applying brakes causing the brakes to drag. I seldom use the rear brake but this shouldn't necessarily constitute a problem, anyone have a simple solution? Thanks
 

·
Premium Member
Joined
·
319 Posts
doesn't return after applying brakes causing the brakes to drag. I seldom use the rear brake but this shouldn't necessarily constitute a problem, anyone have a simple solution? Thanks
Pull the pedal from the shaft, clean, lube with anti seize and re-install.
Not much linkage if you have forward control bike. As mid controls I don't know I don't own one.
 

·
Premium Member
Joined
·
11,366 Posts
I would take the rear master cylinder apart and clean things out. Here is an excerpt from the parts manual to help you out. Part Number 11 is a "Brake return spring". The pictures came from a 2003 V-Rod Parts manual.
 

Attachments

·
Tie One On
Joined
·
1,645 Posts
I would take the rear master cylinder apart and clean things out. Here is an excerpt from the parts manual to help you out. Part Number 11 is a "Brake return spring". The pictures came from a 2003 V-Rod Parts manual.
Thats a forward control schematic, He has mids !

I just got finished tearing my mid brake master control apart and putting it back together because I had to mod it for my dual controls conversion. The inside is nothing special , a few springs, a shaft with rubber piston cups, and a washer or 2 and 2 snap rings.

I am assuming that you probably have a tear or the seal of the top rubber water shield as I call it has come out of the recess and you got water in there somewhere. Take the control off and tear it apart. No special tools and it will only take you about 10 minutes to have it completely torn apart once you have the thing off the bike.
 
1 - 4 of 4 Posts
Top