Harley Davidson V-Rod Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
2 days after i bought my bike and it's raining. Supposed to rain throughout next week too! Decided to take the bike for a ride in the rain just now and am sorry to say that i am a little dissappointed. Didn't expect it to start missing when im hardly a mile away from home. Infact i had to head back home after 2-3 miles to avert a scenario to be stranded with my bike in rain on a sunday!

The japanese bikes they gave us in the Rider Education class never missed or stalled when it rained hard during the 2 days of the class!

Perhaps i should bring it up with the mechanic!

:banghead:
 

·
Non-erator
Joined
·
9,795 Posts
First of all... wait and break the bike in a bit. How many miles do you have on it, 10-20?

I ride mine in major downpours and nothing ever misses. If it keeps missing, yup, bring it back to the dealer....

And if you are REALLY disappointed in it, I can take it off your hands if you are willing to take the hit.
 

·
I know,I know..apes?
Joined
·
506 Posts
I would. I have been caught in the rain many times. Even in a heavy downpour mine never stuttered. Maybe someone else has had this problem.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
Thanks for the quick replies. You guys give me hope!


mikep i have 170 miles on it now and the 'little' 'missing' has happened in the rain only today


mikep said:
And if you are REALLY disappointed in it, I can take it off your hands if you are willing to take the hit.
no thanks! i agree i need to break it further and hopefully all quirks in it will be gone after the 1st service... :D

It only 'missed' a little and didn't really stall, so thats a good sign :D
 

·
Registered
Joined
·
28 Posts
I ride in 'sunny':bs: Seattle. Never had a problem in the rain...
 

·
Registered
Joined
·
72 Posts
I live in south FLORIDA and in the summer it rain's almost every day,I been thought some heavy down pour's ,bike has NEVER stuttered only 1220 miles on it .
 

·
On the dark side
Joined
·
174 Posts
hey welcome! Another NJ DX! Awesome!

On riding in the rain, I've ridden through drenching downpours & the bike's been solid as a rock all the way around. I think this might be an early break-in thing only. Mine loosened up nicely over the first 1500 miles, only gets better with each mile - almost 4000 now.

Send a PM if you want to cross paths, I know a few other local DX'ers too.
 

·
Kicking cancer's ass
Joined
·
969 Posts
Riding in the rain is mandatory in Oregon if you don't want a 45 day riding season. No problems at all here.
 

·
Chrome is king!!!
Joined
·
20,269 Posts
NightRodX said:
hey welcome! Another NJ DX! Awesome!

On riding in the rain, I've ridden through drenching downpours & the bike's been solid as a rock all the way around. I think this might be an early break-in thing only. Mine loosened up nicely over the first 1500 miles, only gets better with each mile - almost 4000 now.

Send a PM if you want to cross paths, I know a few other local DX'ers too.

I can verify that. I was in that same downpour and had no problems.
 

·
Registered
Joined
·
922 Posts
Vrod-Mike said:
I can verify that. I was in that same downpour and had no problems.

:) I think it was about 15 of us were in that storm? Noone's bike failed or missed a beat. Can't say anything good about my cheap rain suit, but the bike ran flawlessly.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #13 ·
Thanks for all ur replies!
From your feedback i am happy to gather that it's not a normal behaviour for this bike and i will further ride it in the upcoming rainy days and see if the problem goes away and if not will get it fixed.

I will be spending next few weeks breaking the bike and getting more used to it and look forward to be there in one of those storms with u guys when u next brave it together... :)
 

·
Registered
Joined
·
225 Posts
Maybe the bike wasn't warmed up. I know if I take off with a warm up it sputters a little. Last no more than a mile or two.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #15 ·
vanslam said:
Maybe the bike wasn't warmed up. I know if I take off with a warm up it sputters a little. Last no more than a mile or two.
No it wasn't warmed up. Maybe that was the reason!
I will make sure i do that every time in future!
 

·
George
Joined
·
5,411 Posts
I ride mine thru the E'glades all the time. Rains so damn hard you can't see 50 feet! NEVER missed a beat in 12K miles!
 

·
On the dark side
Joined
·
174 Posts
Arjun said:
No it wasn't warmed up. Maybe that was the reason!
I will make sure i do that every time in future!
Yes I get some sputters if I don't let 'er warm up before hitting the road. It's so hard not to kick it into gear & just go when it's sitting there running though so I understand the feeling!

Looks like we might have the basis of a good-sized V-Rod contingent in NY / NJ / PA here by the way....
 

·
Registered
Joined
·
2,541 Posts
My bike has had some rough engine running when it is not fully warmed up. Rain or no rain. Some slight chop. It goes away after about five minutes. The rain does not affect it. Maybe you are experiencing the same thing.
 

·
Gone
Joined
·
545 Posts
vanslam said:
Maybe the bike wasn't warmed up. I know if I take off with a warm up it sputters a little. Last no more than a mile or two.
Mine always misses a bit when it's "cold". However, by the time I get to the first big intersection, she's ready to go!!!!!!!!!! I found that the missing lessened as the bike was broken in too. Good luck!!!!!!!
 
1 - 20 of 26 Posts
Top