Harley Davidson V-Rod Forum banner
1 - 6 of 6 Posts

·
Premium Member
Joined
·
1,513 Posts
Discussion Starter · #1 ·
I have been hearing a “Ping” sound off and on for a few months. It happens when I hit a large hole or bump. I was cleaning the bike today and while polishing the belt guard I could see what I first thought was dirt behind the shock. I cleaned it up good with mothers and then can see it is a scratch.

I changed the stock shocks out for the ones with the chrome covers. The shocks clear until you hit a large enough bump and then the cover hits the side of the belt guard. That is the ping I was hearing. It’s already scratched so the hell with it now. Just a heads up if you change to the chrome shocks check you may need to add an additional washer at the top to get clearance.
 

·
Color me Gone
Joined
·
27,333 Posts
I have seen some of the aftermarkets hit, are yours Harley or aftermarket?
 

·
Premium Member
Joined
·
1,513 Posts
Discussion Starter · #3 ·
It’s a stock guard just chromed. The shocks are the newer ones with the chrome covers on them. Purchased both off of Ebay. They came in HD packaging with the HD part number on the boxes. It just barley hits, just enough to ring the bell.
 

·
Registered
Joined
·
201 Posts
My progressives did the same thing.
 

·
# 12/50 Ignite LE
Joined
·
2,913 Posts
Red-Rod said:
I have been hearing a “Ping” sound off and on for a few months. It happens when I hit a large hole or bump. I was cleaning the bike today and while polishing the belt guard I could see what I first thought was dirt behind the shock. I cleaned it up good with mothers and then can see it is a scratch.

I changed the stock shocks out for the ones with the chrome covers. The shocks clear until you hit a large enough bump and then the cover hits the side of the belt guard. That is the ping I was hearing. It’s already scratched so the hell with it now. Just a heads up if you change to the chrome shocks check you may need to add an additional washer at the top to get clearance.
I have the same shocks (p/n 54735-04) still in the box just waiting to go on this winter with some other stuff like ricks tank and 200 tire :blahblah: :blahblah: Anyway, I just opened the box and compared the spacers that came with the chrome covered shocks and my original hardware. You should have gotten a shock mounting kit with the shocks (labeled 54735-04-SUBA), the kit has a longer top spacer and a small spacer for the bottom to take up the difference for the longer top spacer. This will move the shock outward.

Did you reuse your existing harware? Did you just get the shocks with no hardware off of ebay?
 

·
Premium Member
Joined
·
1,513 Posts
Discussion Starter · #6 ·
sammy said:
I have the same shocks (p/n 54735-04) still in the box just waiting to go on this winter with some other stuff like ricks tank and 200 tire :blahblah: :blahblah: Anyway, I just opened the box and compared the spacers that came with the chrome covered shocks and my original hardware. You should have gotten a shock mounting kit with the shocks (labeled 54735-04-SUBA), the kit has a longer top spacer and a small spacer for the bottom to take up the difference for the longer top spacer. This will move the shock outward.

Did you reuse your existing harware? Did you just get the shocks with no hardware off of ebay?
Didn't get the (suba) with the shocks. That is the answer. Thanks
 
1 - 6 of 6 Posts
Top