Harley Davidson V-Rod Forum banner

1 - 5 of 5 Posts

·
VRSCF Road-Rod Owner
Joined
·
328 Posts
Discussion Starter #1
I just bought a PCV for my 09 Muscle, and am considering buying a Dynojet Auto-tune add-on (AT-100) as well.

I've heard of some bikes (not necessarily V-Rods) having an exhaust port that wasn't the same size as the Dynojet sensor - the fix was to drill the pipes for a larger opening so the Dynojet sensor would fit.

Can anyone who's tried this combo let me know if the standard fitting worked, or whether installation of the Auto-tune module required modification? Thx...Q
 

·
Registered
Joined
·
818 Posts
I just bought a PCV for my 09 Muscle, and am considering buying a Dynojet Auto-tune add-on (AT-100) as well.

I've heard of some bikes (not necessarily V-Rods) having an exhaust port that wasn't the same size as the Dynojet sensor - the fix was to drill the pipes for a larger opening so the Dynojet sensor would fit.

Can anyone who's tried this combo let me know if the standard fitting worked, or whether installation of the Auto-tune module required modification? Thx...Q
The only problem is that you need to tweak the rear bung a little to help clearance the O2 sensor from the rear cylinder. The wide band O2's are a little longer then the stock ones.

I did not do this to mine and I have not had an issue. Did have to remove the exhaust to install.
 

·
Banned
Joined
·
3,309 Posts
I just bought a PCV for my 09 Muscle, and am considering buying a Dynojet Auto-tune add-on (AT-100) as well.

I've heard of some bikes (not necessarily V-Rods) having an exhaust port that wasn't the same size as the Dynojet sensor - the fix was to drill the pipes for a larger opening so the Dynojet sensor would fit.

Can anyone who's tried this combo let me know if the standard fitting worked, or whether installation of the Auto-tune module required modification? Thx...Q
There are two or three posts here from fellows who can't seem to get the autotune to work right on the Muscle. I don't know any of the background, but it might be worth your while to read a bit more before pulling the trigger on the autotune unit.
 

·
Registered
Joined
·
818 Posts
There are two or three posts here from fellows who can't seem to get the autotune to work right on the Muscle. I don't know any of the background, but it might be worth your while to read a bit more before pulling the trigger on the autotune unit.
Could you link me to those posts. I tried search but it did not locate those having an issue.

I was one with tuning problems but have had no issues with functioning.
 

·
Registered
Joined
·
74 Posts
Do the autotune ... I am continually amazed at how good it works in any condition. My bike is DX and I had the issue of having to tweak the #2 cylinder bung just a smidge (did it with a TIG torch while on the bike) but the wide band sensor uses same threads.
 
1 - 5 of 5 Posts
Top