Harley Davidson V-Rod Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have recently bought Vance and Hines competition series pipe for my 06 nightrod..I have less than 2000 miles on these pipes and yesterday on my way to work one of the oxygen sensors came off of the pipe...i later discovered after it cooled down and I could touch it to screw it back in that the sensor looks to be aluminum and the threads were worn out and wasnt able to hold a thread...Is this a common problem?..i was wondering if i could put a bolt of that size in place of it and if it would be any danger to the bike?..I paid alot of money for these pipes and for this to happen makes me furious!!..please help guide me to do what needs done!!
 

·
Friend of Max.
Joined
·
21,715 Posts
1. Why does your 2006 have O2 Sensors?
2. Call Vance and Hines and let them know what happened. They are good at helping customers out.
3. If that fails, take the pipe to a muffler shop and they can weld a plug in place, or even replace the 02 sensor bung.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Im just figuering they were oxy sensors on the competition series pipes...There is what looks like a bolt on both pipes that come out of the motor...I take it that it isnt oxy sensor?..i dont know what they are but I do know that there made of aluminum perhaps.....have you ever heard of anyone with this issue?..I thought of replacing them with a steel bolt of some sort but not sure if it can cause any problem for the bike..
 

·
Friend of Max.
Joined
·
21,715 Posts
Im just figuering they were oxy sensors on the competition series pipes...There is what looks like a bolt on both pipes that come out of the motor...I take it that it isnt oxy sensor?..i dont know what they are but I do know that there made of aluminum perhaps.....have you ever heard of anyone with this issue?..I thought of replacing them with a steel bolt of some sort but not sure if it can cause any problem for the bike..
Ahhh. Those are just plugs for the 02 Sensor bungs. I presume the "bolt" is what came out of the pipe. You can replace that with a standard plug.

I would call Vance and Hines. They'll probably ship one out to you.

FWIW those "plugs" are where o2 sensors plug into, if your bike uses them (2008 and up and some aftermarket ECM's.) The 2006 with a standard ECM doesn't use o2 sensors.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
RJ thanks very much..I will call vance and hines when they open up today...Your help was very much appreciated....
 
1 - 6 of 6 Posts
Top