Harley Davidson V-Rod Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Please help :) Nightrod 2015
Engine management light (overheating ) comes on when running slow in traffic.
when I check the codes it says, P1482 fan Fault.
However , when the bike is on the side stand running up, the fans come on a few seconds after the engine management light comes on.
we are slowly checking all connections and found a little corrosion on the rectifier and fan connectors (all clean now).

ps , great forum !
 

·
Registered
Joined
·
2,510 Posts
i dont think the fans operate over a certain speed.your problem could be tripple sprocket bolt loose.if not.blockage in radiator or thermostat not working.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
i dont think the fans operate over a certain speed.your problem could be tripple sprocket bolt loose.if not.blockage in radiator or thermostat not working.
Thank you for the advice. we’ve checked the triple sprocket bolt, which is all good. I’ll move onto the thermostat , once I’ve found it :).
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Found the problem!
needs a new ECU. Harley have run a full set of checks and all sensors ok.
going to be expensive the problem is sorted 👍
 

·
Registered
Joined
·
827 Posts
Yes the fans do come on at speed. Mines do, it just depends on engine temp. I have an led wired to my fan relay, and the fan do run at any speed if temps require them to.
 
1 - 6 of 6 Posts
Top