Harley Davidson V-Rod Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
327 Posts
Discussion Starter #1
Hello guys,

My 2009 AW has been on a battery minder for some time. I went to use the bike the other day. The alarm, lights, horn, etc., work.

Run switch on, no fuel pump. Hit the start switch, nothing. No click, nothing.

I am certain that this is an easy fix, fuse, relay(s), etc. I have searched the forum and I can't find the fix. What am I looking for ?

Fuzz
 

·
Registered
Joined
·
3,732 Posts
Hello guys,

My 2009 AW has been on a battery minder for some time. I went to use the bike the other day. The alarm, lights, horn, etc., work.

Run switch on, no fuel pump. Hit the start switch, nothing. No click, nothing.

I am certain that this is an easy fix, fuse, relay(s), etc. I have searched the forum and I can't find the fix. What am I looking for ?

Fuzz
Not to be a wise ass but is the kill switch off? It's always the stupid shit that get's ya. LOL
Ron
 

·
Registered
Joined
·
359 Posts
When was the last time you changes the battery in the key fob?
Harley recommends changing the every 2 years, and will go dead by 3 years.
 

·
Premium Member
Joined
·
11,205 Posts
The fuel pump gets its juice from the system relay through the Fuel pump fuse. Check the fuse, or better yet replace it and swap the relay with one of the other relays. They are all the same. look for changed symptoms
 

·
Registered
Joined
·
2,485 Posts
sounds like an earth problem.loose batt terminals ,earths on front and rear heads.that copper L shaped connector on front head,remove ,clean contacts,refit.
 

·
Premium Member
Joined
·
327 Posts
Discussion Starter #10
When was the last time you changes the battery in the key fob?
Harley recommends changing the every 2 years, and will go dead by 3 years.
And how does the key fob affect start/fuelpump when everything else electric works ?
 

·
Premium Member
Joined
·
327 Posts
Discussion Starter #12
The fuel pump gets its juice from the system relay through the Fuel pump fuse. Check the fuse, or better yet replace it and swap the relay with one of the other relays. They are all the same. look for changed symptoms
Thanks. I will check those.
Fuzz
 
1 - 12 of 12 Posts
Top