Harley Davidson V-Rod Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I just arrived home from afghanistan just installed a turbo ricks tank and I am having trouble with the new clutch. I started the bike backed it up and I couldn't pull in the clutch to get it in gear it is not engaging at all the clutch is a performance one clutch with the extra plate any help would be greatly appreciated
 

·
Registered
Joined
·
1,037 Posts
Sounds like you have air in the system and just needs bled. I had the same thing happen after an offshore stint I did. Bled the clutch and voila I was on the road again.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
I read somewhere about not spinning the clutch basket and the basket spun when I was removing the clutch nut could that have an effect? when you had that problem could you pull the lever in at all? mine is stuck out and has no pull at all
and what is the process of bleeding the clutch
?
 

·
Registered
Joined
·
1,037 Posts
My lever would pull in but there was no resistance when you pulled it in. I am not sure about why you lever would pull in other then an interference with the release push rod.... I would look more into what you are talking about if you lever is not moving.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Looks like it's going to the shop tomorrow followed the instructions step by step and still had no luck. I can pull the clutch in now but it's not engaging. I have also bled the lines as you suggested.
 

·
Friend of Max.
Joined
·
21,719 Posts
Stop...

You need to go back into the right side cover and make sure you have everything buttoned up correctly.

It sounds like the basket came off when you were changing the clutch. If that's the case, and you didn't line the clutch basket back lash gear correctly, then the clutch basket may not be completely seated, which is why you can't pull the clutch lever.

Go back. Take a look at the gears on the clutch basket and make sure you're completely seated.

If you don't have a manual, you need one.

If the clutch was working, then stopped working after you put it back, then something isn't right under that cover.
 
1 - 7 of 7 Posts
Top