Harley Davidson V-Rod Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
239 Posts
Discussion Starter #1
before some tells me to hit the seach buttom ,i have and didnt get any answers,i received my killer glass kit the other day,on the instruction there should have been an led epoxied into the glass ,it wasnt, it was just loose.can someone tell me if i have done it right with the photos i have supplied.or have i stuffed it up.
 

Attachments

·
Premium Member
Joined
·
351 Posts
Don't go off me, but that led looks backwards. I've never seen an killer glass kit, but it seems like the led itself should be towards the glass.


Sent from my Motorcycle iPad app
 

·
Registered
Joined
·
239 Posts
Discussion Starter #4
it just doesnt look or feel right when i turn it around , no doubt it wil be something easy ,you can call me STUPID now:bash:
 

Attachments

·
Premium Member
Joined
·
351 Posts
Looks like it should go the other way, but is the led suppose to light the coolant hose or the engine? Like I said I have zero experience with this thing but that's just makes sense to me.


Sent from my Motorcycle iPad app
 

·
Registered
Joined
·
239 Posts
Discussion Starter #6
its supposed to light the glass ,there is nothing in the instructions about led installment on to the glass at all
 

·
RIP Nigel & KAK
Joined
·
942 Posts
Yea alex2494 got the same kit which we installed. It was different from mine which was already epoxied in. We pushed the led off the lil plastic bracket it's attached to and just zip tied it to it and the took some epoxy and dipped it around the led and let sit over night. We put it higher on the glass towards the top closer to where the hose attachs to.
 

·
RIP Nigel & KAK
Joined
·
942 Posts
And just noticed u had the wire and ribbon wrapped around the glass. The ribbon and wire run with the coolant hose up to air box if that's where you are wiring it to. Not around it. If you want pics I'll get ya some later on.
 

·
Registered
Joined
·
239 Posts
Discussion Starter #9
pics would be great man,thanks .instructions are very vague.on the pics i have in front of me why is there a wire running in between gator clamp and the coolant hose if led is epoxied to out side of glass .thanks for your help crazy2sin

got the general idea now.
 

·
Registered
Joined
·
962 Posts
fitted mine (same as above ) last year

1) the led is not in the glass anymore !
2) the led light output faces the glass towards the coolant.
3) the ribbon is part of the wiring and circuit so treat it as wire and heat shrink it away from the glass (as if its a wire coming from the LED)
4) placed mine at the top of the glass around the gates heatshrink so you can barley see the zip tie
5) works perfect and lights up coolant even through it towards the top of the glass.
6)never used any sealant just the zip tie and it has never moved.
7) run the ribbon and wire through cable heat shrink and route following the hose towards airbox then to an ign live and earth (took mine from under the riders seat and routed cable with other cables to keep it neat.

no one ever notices the zip tie or can see the LED as its behind the glass at the top, but lights up a treat !

all the above was easy , but getting the hose off the replace with the killerglass was a PITA !

hope this helps
 

·
Registered
Joined
·
239 Posts
Discussion Starter #11
thanks nfn got mine installed now ,basically the same as you described ,thanks everyone who responded ,will post pics later
 

·
Registered
Joined
·
239 Posts
Discussion Starter #12
sorry not very good pics ,after the drama of not knowing where to install the led,i figure,d it out.the instruction were useless .computer wont allow me to upload photos on this thread ,because i have allready posted photos on the australian section of 1130cc
 

·
Registered
Joined
·
290 Posts
I installed mine like nfn did except I didn't put any of hte led wire under a heat shrink clamp. I've had to replace my led due to the wiring breaking off right at the heat shrink previously and decided that was unnecessary. Now if something goes wrong all I have to do is cut the zip and put another led in place of the old one! No expoxy, no removing the glass, no messing up the radiator hose!
 

·
Registered
Joined
·
962 Posts
porky= i never put the wire under the gates clamp ? why would anyone want to do that when the LED is now not glued into the glass ?

i used wire heat shrink(not gates heat clamp) to protect the flat ribbon and LED wire and ran that up the outside of the killerglass heat clamp , so it too can be easily removed one snip and its free !

i have also used a "Muscle" top hose cover which is just the right size to cover up the top gates heat clamp and gives it a pro finish !
 
1 - 14 of 14 Posts
Top