Harley Davidson V-Rod Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
Okay I have had issues with my DX. At first I had a leaking loose coolant hose. Then the throttle housing screw kept coming loose. AT about 1,000 miles and headset knocking bearings needed to be tighten.

Now I have a bad rear shock, an exhaust leak in where the slip on canisters connects to the collector and a bad fuel gauge level. Lucky its all being fixed under warranty.
 

·
Registered
Joined
·
186 Posts
Man, lemon. I haven't had any problems at all and just hit 1500. My 02 V-Rod went 30k+ miles with no problems at all. Good luck!
 

·
Army spark jockey
Joined
·
3,091 Posts
man that sucks, havent had a bit of trouble out of my 07DX
 

·
Registered
Joined
·
2,809 Posts
That does suck...I hope your dealer is helping you with no issues on those fixes!!
 

·
Registered
Joined
·
225 Posts
Discussion Starter #7
JDR_ROD said:
That does suck...I hope your dealer is helping you with no issues on those fixes!!
The dealer Trenton Harley has been great, they jump on the problems and are covering the cost (HD warranty).
 

·
Trailers R 4 Boats
Joined
·
1,271 Posts
I had an exhaust leak, I didn't care about it because the exhaust wasn't long for this world.
 

·
Registered
Joined
·
113 Posts
I only had one small problem the battery wasn't keeping it's charge I cant remember what they replaced but I just turned 3000 miles, hope to get a couple mor in before the snow
 

·
Slave to my DX
Joined
·
75 Posts
EZE RIDER said:
Except my fuel gauge.
i am having that same issue, where fuel level stays the same or shoots up to full no matter how much fuel i have.
 

·
Registered
Joined
·
142 Posts
I had problems... the clutch lever/directional assembly fell off in my hand at 400 miles and it was mis-shifting alot during the first 800 miles. Locktite took care of the clutch screws and the gearbox took care of itself after doing some more mileage. Problem free at this point.
 

·
GA. BOY
Joined
·
2,462 Posts
vanslam said:
Okay I have had issues with my DX. At first I had a leaking loose coolant hose.
welcome to the club!!
 

·
Clown OnBoard
Joined
·
658 Posts
At 500 miles my clutch control came off also. Had problems getting into first but it worked itself out. No fuel gage problems yet. Had a bad ground that caused the instrument lights to go bright and dim. I now have 1700+ miles and going strong ...so far.
 

·
Comfortably numb!
Joined
·
1,968 Posts
Have 5k miles and only issue with mine was loose bolts, but that is an expected issue. Oh yea, picked up a huge nail in the rear tire yesterday... Can't blame Moco for that tho ;)
 

·
Registered
Joined
·
225 Posts
Discussion Starter #20
Still waiting for parts. But this is an american bike why do I have to wait for parts... I knew this was going to happen, so I am still riding my non perfect highly priced motorcycle until they come in.

Sad to know that a 16k+ bike can have basic quality issues and we the rider/owner accept it. This is why the Jap bikes and cars are eating our lunch. HD get a clue.
 
1 - 20 of 22 Posts
Top