Harley Davidson V-Rod Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Hi, I'm having exactly the same problem. Additional, when I switch on the power switch, the Engine light lights on, goes off and after a few seconds it's on again for a second test.
I'm currently guessing, that the battery is involved.
 

·
Premium Member
Joined
·
1,302 Posts
lights stayed on for 15 mins. or so. 2nd. time this has happened.
Any comments would be appreciated
First, don't run it with the engine light on. Second, see if you can pull a code on it!
 

·
K.I.A. '07 AW
Joined
·
10,908 Posts
check codes, clear codes, restart
 

·
Road rash hurts!!!!
Joined
·
191 Posts
I had this problem which stealership never discovered the cause but it started with a simple connections they thought needed cleaning, then it was because it was a historic fault - ended up couple months later bike broke down on the way to stealership battery was not holding charge, couple of parts where replaced regulater new plactics around regulater/radiator and the stater was burnt out. Keep an eye on it get them to check regulater and stater.
 

·
Premium Member
Joined
·
11,390 Posts

·
MOVE !!!!!!!!
Joined
·
232 Posts
Hmmm not mmmmmmm!!

http://www.1130cc.com/forums/showthread.php?t=3&highlight=diagnostic+trouble+codes

http://www.1130cc.com/forums/showthread.php?t=2&highlight=trouble+codes

The list of codes iis relatively old. Newer bikes may have new codes not listed. If yours is not post it hear and someone can look them up/.
Thanks Rusty I needed to find and save those threads for future ref. Oh and I know I'm knit picking but I saw "MMMMMM engine and lights" and was like ohhhh yeahh!!! Then I saw this thread and it was very informative but I wanted eye candy =\ so now GIVE ME EYE CANDY!! LOL hope you fix your problem tho.
 

Attachments

1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top