Harley Davidson V-Rod Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Last night I installed the pigtail for a Battery Tender Plus by disconnecting one battery terminal at a time. While working with the positive terminal I could hear a noise coming from the instrument cluster each time the cable would come in contact with the battery terminal. The noise was similar to the noise you would normally hear when you turn the ignition key to the run position. This morning when I started the bike I checked the odometer and found that the mileage had decreased by about 300 miles. I know I was just over 3000 miles and the odometer now shows 2750+/-. Does anyone have any idea why this would happen?


Thanks,
Paul
 

·
Banned
Joined
·
12,582 Posts
Thats Some Freaky $hit! :confused:
 

·
Registered
Joined
·
454 Posts
The noise coming from the cluster is normal however it shouldn't have lost the milage. Are you sure you're not looking at one of the trip meters (it's got 2 if I remember correctly)?
 

·
Color me Gone
Joined
·
27,333 Posts
ptrnfan your not the first report I have read about strange odometer changes. There may be an electrical glitch effecting the memory that the mileage is stored on from time to time.

Max
 

·
Registered
Joined
·
373 Posts
I like that. Still got the new sticker off the rear view mirror. The old rod (2002) could be detailed and born again. LOL
 

·
Registered
Joined
·
218 Posts
ptrnfan,
Remember in the movie "Animal House" when the big parade at the end was coming unglued and a girl dressed as a Playboy Bunny landed on the boy's bed while he was reading the mag of the same name? He wasn't all concerned about why and how come. Be glad it didn't ADD 5000 miles!
 
1 - 9 of 9 Posts
Top