Harley Davidson V-Rod Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
So I’m completely lost with my 2006 VRSCR. I’m very inexperienced with anything on Maintenence, but I replaced my taillight and went to start my bike and noticed my fuel pump not coming on and the system relay clicking really fast. My bike did not try starting at all. I then tried jumping my bike because I knew the battery was dead (using my car to jump it, I know that’s a mistake) but got nothing. At this time my display lights were working, front leds around the front turn signals lit up but not the turn signals themselves and not lights in the rear turned on. Well I replaced my battery completely, hooked it up and tried starting the bike to have absolutely nothing happen now. Only thing that happens is my headlight will come on, but no display lights, fuel pump will not come on, and now no noise from the system relay. Thinking it is an electrical issue, but as being completely inexperienced with any of this stuff I’m lost.
Any help would be greatly appreciated. Thanks!
 

·
Registered
Joined
·
658 Posts
Check the easy stuff first. Check all fuses. Check the main fuse on the right side of the neck. This happened after a tail light swap so yes, most likely electrical. You may have to retrace your steps.
 

·
Registered
Joined
·
364 Posts
Batteries DO NOT LIKE TO BE FULLY DISCHARGED.
Fully discharging (i.e. letting it die over the winter) it builds scale up between the cells which take years off of it not hours of days but years.

also run an alternator test and voltage regulator test. There's a sticky over in the technical section i wrote a few years back when i was diagnosing a wonky voltage regulator. Burned up a brand new battery in the process of diagnosing it due to repeated discharges.
 
1 - 3 of 3 Posts
Top