Harley Davidson V-Rod Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
284 Posts
Discussion Starter #1
G'day everyone.
I've been hearing some loose metalic sound from my front end for some time, and tonight after cleaning my wheels following riding in the rain, I noticed my front Rt hand Brake disk is loose, ie 3 mm travel along the axis of the mounting bolts.
As I'm not familiar with "Floating Discs", should there be any movement in this disk?
I havent noticed it in the other two discs at all.
The bolts seem tight, although I didn't re torque them as my torque wrench requires recall after a mate played with it, and my work shop manual doesn't say anything of assistance.
Going on the Ingham Toy run tomorrow, so want the bike right.
Any info appreiciated.

Best wishes.
 

·
Color me Gone
Joined
·
27,333 Posts
After reading your post I double checked all 6 rotors (2 v-rods) and none of ours have any movement at all. It appears to be a spring washer that actually holds the rotor tight is there any chance they are in backwards or missing from that rotor? Has the wheel or tire ever been off before?

Max
 

·
Registered
Joined
·
284 Posts
Discussion Starter #3
G'day Max.
Thanks for the reply.
No, the rotor has never been removed.
Yes, I have the same spring washer assembly as you, and all parts are insitu.
My understanding is that the rotors have the washer set up to allow some movement (propably an un noticable amount) of the disk, thus allowing better contact with the pads, hence the term "floating" Also allows better cooling. As there is 2 - 3 mm movement in the Rt hand unit, I suspect it needs torquing down, but I wont do this until definitive information.

Best wishes mate.
 

·
Registered
Joined
·
284 Posts
Discussion Starter #4
Got the bike back from its 4000km service today.
Re the disk, they need to relace all of the spring washers that attach the rotor. Seems they may have gotten past HD quality control.
They wont nip up any more, so I'll advise if the new washers make any difference.

Best wishes all.
 

·
Registered
Joined
·
284 Posts
Discussion Starter #5
31 Dec 03
Still waiting for the washers to arrive in OZ!
At least I'm not riding much due to the Power Commander being stuck in Aussie Customs.
New years eve, have a great night everyone.

Ken.
:cheers:
 
1 - 5 of 5 Posts
Top