Harley Davidson V-Rod Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Hi group.
Is it normal for the clutch pedal to be a little loose? I had to replace the bolt (got broken) but pedal still have a little play (not like brake side that is fully stable. It was that way when I bought the bike 6 months ago. Bolt got broken last weekend. I replaced it with another bolt that fits (length and diameter) from my other bike (suzuki m50) that I had spare. Not sure if its same kind of metal (though replacement felts harder).
Thanks
 

·
Registered
Joined
·
2,056 Posts
Hi group.
Is it normal for the clutch pedal to be a little loose? I had to replace the bolt (got broken) but pedal still have a little play (not like brake side that is fully stable. It was that way when I bought the bike 6 months ago. Bolt got broken last weekend. I replaced it with another bolt that fits (length and diameter) from my other bike (suzuki m50) that I had spare. Not sure if its same kind of metal (though replacement felts harder).
Thanks
There shouldn't have been a bolt in there. The correct fitment is a clevis pin with a retaining circlip. The lever has a bush in it for the pin to pass through, make sure this bush is not missing or you will have a very loose lever. If your bike is an 06 on then you can buy the pin and bush as a kit. Pre 06 they are separate.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #3 ·
There shouldn't have been a bolt in there. The correct fitment is a clevis pin with a retaining circlip. The lever has a bush in it for the pin to pass through, make sure this bush is not missing or you will have a very loose lever. If your bike is an 06 on then you can buy the pin and bush as a kit. Pre 06 they are separate.
Thanks for your reply. My ride is 05, as far as I can tell, the pedals are not the factory ones, they are HD, but not the originals. Below a crappy photo of the brake side pedal and the broken bolt from clutch side. Also a photo of where the bolt came from.
Thanks
 

Attachments

·
Registered
Joined
·
2,056 Posts
Thanks for your reply. My ride is 05, as far as I can tell, the pedals are not the factory ones, they are HD, but not the originals. Below a crappy photo of the brake side pedal and the broken bolt from clutch side. Also a photo of where the bolt came from.
Thanks
I think we are at cross purposes, when you said clutch I assumed you meant clutch lever. That is the gear lever you are pointing to in the picture and they are not the standard controls either. They look like they are probably reduced reach controls and I have no experience with those at all so I'm afraid I can't really help. Sorry.
 
1 - 4 of 4 Posts
Top