Harley Davidson V-Rod Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi everyone. So I went to visit my wife's family in New york a few weeks ago and pulled the hasty trigger on a rough old 07 Nightrod special paint was in bad shape and had 21k on it so he offered it to me 4400. Having never heard of let alone ridden one After I drove it, I had to have it.He shoed me the book of nearly 7k for on with typical mileage. and i reasoned 'who cares , it black and baddass. The guy seemed earnest. Turns out .Not so. Now i know this thing has been beat near to its death after spendig the last two weeks with it. I love it, and its been running great from my limited perception. However, I found bolt missing , then two. Then dug in. Things are missing everywhere that I didn't know until . In the machines defense it rides great but I'm afraid its just not safe until i know it inside and out and then , Il probably still take it to Hd to give it a last look over.. I hope to make it that way again. I need to solve some mysteries. Thats were you guys come in.

#1 My motor mount is missing a bolt and not lined up.,

#2 the swing arm pin appears uncentered, laying almost to the rear of the hole towards the back of the bike.

#3 Add to that : at one time , the belt at one time, has run clean through the gas tank. I am now told its no longer an issue ( by the same guy who sold it to me) as he had a "Honda" dealer repair the tank. He said its the patch that I'm seeing though it looks like a wear mark.



HELP!! Could the first three things be related?

At least I repaired the blown hose on the rear cylinder that was blowing oil last night nd I have new tires.???
 

·
"Vrod King"
Joined
·
871 Posts
Sounds like a bunch of minor issues. Things to do 1. Get yourself a services manual for it. 2. I would replace the tank. I have seen ones on eBay. $4400 is not bad.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3 (Edited)
Let me show you two pictures of this swing arm pivot bolt as seen from above and behind ( Left Side) and one of the right side of the bike. There is a bolt missing at the motor moun on the right side of the bike. The old rusty tab is a part of the included 'Toxic Pipes" and I have no idea how to line the motor mount up to the frame to get another bolt in there. Is there a chance that Installing the missing motor mount bolt into the frame will center that swing arm on the other side of the bike or is this even a problem? the bike runs and rides great. No vibration, smooth as butter but i wont be riding anymore until i figure this out.
605180
 

·
"Vrod King"
Joined
·
871 Posts
There are no bolts to the left side mount (it's welded to the frame). The right side should have 2 bolts (top and bottom) for the motor mount. Looks like the top bolt is missing which caused all the problems your are having. You will have to pull the rear tire off and the swing arm too. Change the tank and replace the two rubber motor mounts. It's not hard to do. Some of the guys on this forum can (and have) this job in under 2 hours with a break time in the middle.
 

·
Registered
Joined
·
4,263 Posts
Don't know about the right side but left side mount is totally pooched. Yes, there are no bolts in the left sides, only the right.
Ron
 

·
Registered
Joined
·
112 Posts
Sounds like a bunch of minor issues. Things to do 1. Get yourself a services manual for it. 2. I would replace the tank. I have seen ones on eBay. $4400 is not bad.
Did 2007 already have the bigger tank or did that come later? If it still has the smaller tank, I would look at one of the Unlimited Engineering V-Rod tanks that are bigger and give a lot more range. If you're gonna spend the money replacing the tank anyway, you may as well do yourself a favor if you have a little tank. I would.
 

·
Registered
Joined
·
148 Posts
Perfection is achieved 1 little bit at a time .If it was me, I'd invest in a service manual and start tackling one thing at a time. For sure, if those mounts are loose
Your entire drive train is misaligned. I just bought a old neglected Honda for my wife which I stripped down to only the frame and motor after getting it running and test driving it. It nearly ran it self into the curb, so I removed the forks
To determine how bad the issue was, they were bent only about
10 MM. So in my case that's all it took to screw up the whole thing.
 

·
Registered
Joined
·
484 Posts
Did 2007 already have the bigger tank or did that come later? If it still has the smaller tank, I would look at one of the Unlimited Engineering V-Rod tanks that are bigger and give a lot more range. If you're gonna spend the money replacing the tank anyway, you may as well do yourself a favor if you have a little tank. I would.
2007 was wide frame and already has the 5 gallon tank
 
1 - 12 of 12 Posts
Top