Harley Davidson V-Rod Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Hi guys,

I bought and installed a led tail light (with integrated turn signals) but the "flash breaking" is not registering when I brake. The light stays always red with the same intensity.

I have contacted the seller on Amazon but if you have an idea to resolve it, it will be much appreciated.


Thanks in advance.
 

·
Premium Member
Joined
·
11,390 Posts
Sounds like you got the wrong unit. ITU:LED is the one with 6x flashing. Which one did they send you?
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #4 ·
Some news guys, the issue is coming from the brake switch and not the tail light. Apparently my brake switch is stuck in « on position » meaning that the light receive a braking signal at all time.
Do you know where I can find and repair the brake switch ? Are there several ? Thanks !
 

·
Registered
Joined
·
2,058 Posts
No, the one I described was the rear brake one. Not quite sure why I assumed you were talking about the rear!! The front one is inside the handlebar switch housing. Remove the lever first before opening the housing or you will snap its little pin off. It is a bit of a PITA to change as its not easy getting all the wires in the right place when you reinstall the housing. Take your time and don't force anything as it's very easy to pinch a wire.
 

·
VRSC est -03
Joined
·
3,162 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #16 ·
Update: you were right the issue is with the front brake switch. When the clutch lever is in « stand by », the nipple of the switch brake doesn’t stand out enough (like 1mm) hence the light tail being in brake position all the time. I’ll have to change the whole switch I guess.
606687
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #17 ·
So guys, I fucked myself twice. I changed the brake switch, it was a real bitch and pain. :)
Did not solve anything, the issue was from the contact between the clutch lever and the tits of the switch. Did not know what to do so I glued a small coin to the lever in order to amplify the contact. Worked until it did not. Then the tits of the switch was fucked because of the coin, the tits was too much inside and wouldn’t free itself.
Do I try to open all the sucker again (the bitch and pain one) in order to « release » the tits to its former position ? Do I do it ? Or will I fuck myself a 3rd time ?
Thanks guys.
 

·
Registered
Joined
·
2,058 Posts
I did, why ?

Edit: the issue came with the stock lever though
I only ask because the early and later levers are slightly different and I believe one of the problems if you use the wrong year levers is a problem with the brake light switch, but if you had the issue before the swap then maybe it is not this. Unless the original problem was a switch and then you fitted a new switch and the wrong lever together.
 
1 - 20 of 24 Posts
Top