Harley Davidson V-Rod Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
My ignition switch is not working right, adjusting it can cut the bike off or not let it start, or make the blinkers/horn/brake light not work. Has anyone taken one apart and cleaned it?
 

·
Premium Member
Joined
·
11,358 Posts
I had problems with mine a while back and discovered the switch can be dis-Assembled from the rear. Remove the C-Clip on the back side Gently pull the switch apart.
CAUTION: There are three real small springs and U-like connectors covering them.Also a large center spring. They can get lost in a real big hurry. The three springs fit in three holes and the U connectors cover them.
Just take your time and clean and lubricate everything using Di-Electric grease to insulate parts from corrosion. It can go back together only one way.
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #4 ·
Thanks mates! will try these.
 

·
My Last Ride
Joined
·
1,347 Posts
Thanks mates! will try these.
The problem starts due to the sliding contacts losing lubrication. Without lube they tend to grab and turn sideways in the switch body. When that happens then the switch is stuck.

Disassemble the switch taking care not to lose pieces.

Use cleaning solvent and wash the housing and individual pieces.

Lubricate moving parts with dielectric grease.

Reassemble switch.
 

·
Registered
Joined
·
10 Posts
Just wondering how the switch is mounted? Specifically the tooling bit to remove the ignition housing from its mount?
 
1 - 6 of 6 Posts
Top