Harley Davidson V-Rod Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hey crew.

For the last year on my 2006 VRSCR I would flip my switch to IGN and it would only half engage and I would have to wiggle it for the dash to come on.

I took the battery out to trickle charge it. Everything was fine. Today I put the battery back in. Even on “off” the front blinker lights come on, and don’t come off (again ignition is on off). When I switch it to IGN, the head light comes on, and you can turn on the blinkers, brakes light come on, but the dash does not. So it won’t start.

I feel like the MUST be the ignition switch right? Anything I’m missing? I have a video I can post to YouTube if that helps. Please help!!
 

·
Registered
Joined
·
82 Posts
I have an 07 D-model and a couple years ago I had very similar things happen with my lights,instrument cluster etc. I even had the ignition shut down while riding a couple times. I thought it was related to the ignition switch so I took it all apart and found the contacts very dirty. I cleaned everything up, added a touch of electrical grease and put it back together. I haven't had a problem since. I'll try to upload a couple pics of the dirty contacts.
 

Attachments

·
Registered
Joined
·
2 Posts
I owe a2005 vrod shut it off an hour later try to start , nothing lights come on turn signals are flashing can anyone help ?
 

·
Registered
Joined
·
4,086 Posts
While I likely have a slightly different verson on my 13, I did take it apart cleaned the contacts and used dielectric grease on the contacts to help prevent oxidation. So far, all good. The plastic detents are a bit cheap ass and some normal good quality grease in that area keeps it working smoothly without that sticking notchy feel to it.
Ron
 
1 - 5 of 5 Posts
Top