Harley Davidson V-Rod Forum banner

1 - 16 of 16 Posts

·
myvrodrocks
Joined
·
6,021 Posts
Discussion Starter #1
Well....me again. Bad luck or I don't know what I'm doing. Anyway...the intercooler charge pipe decided to work its way over and touch the corner of the valve cover. Rubbed a hole right through the pipe. Little jb weld and I'm back on the road....but this winter the pipe is coming off and will be modded to have more than 0.00001 inch of clearance between the frame and engine. :banghead::banghead:

Anymore modifying of this kit and I will have built it myself.

Pics of the new and improved BOV location will follow once I talk to my welder.
 

·
Gone
Joined
·
9,302 Posts
I had to clearance headers on a big block vette with a baseball bat and a hammer. Worked great, nice clean round dimple.
 

·
myvrodrocks
Joined
·
6,021 Posts
Discussion Starter #5
Yea....great fix and works fine. now with a hole I can't do that or I'll have a bigger hole. I am going to have a square cut and a plate welded in making a flat angle around the cover.


600 bucks the f$%er should fit...

I love my turbo, but as with any custom aftermarket part, there are issues here and there...
 

·
Autobanmod
Joined
·
9,896 Posts
One of the disadvantages in building your own kit is that you can't blame anyone else but yourself if something breaks :D
 

·
myvrodrocks
Joined
·
6,021 Posts
Discussion Starter #7
One of the disadvantages in building your own kit is that you can't blame anyone else but yourself if something breaks :D
True....but you get more pissed off when you have to correct someone else's work. Especially when you paid an arm and a leg for it. 600$ turbo and the kit costs 5k$. For what? Parts that don't fit...

And the BS that they stand behind it? Not mine.
 

·
Premium Member
Joined
·
3,516 Posts
True....but you get more pissed off when you have to correct someone else's work. Especially when you paid an arm and a leg for it. 600$ turbo and the kit costs 5k$. For what? Parts that don't fit...

And the BS that they stand behind it? Not mine.
Did you talk to Nick directly?
 

·
_NoHighLikeMostHigh_
Joined
·
2,160 Posts
Mine was rubbing on the frame (which i took care of a couple years ago) but also now that you mention it I did see a hole working its way from the valve cover corner.

Thanks for the heads up. I did some pounding and glued some rubber to the charge pipe and now all is well.
 

·
myvrodrocks
Joined
·
6,021 Posts
Discussion Starter #10
I'm just gonna find a longer hose to cover the hole. The clamp would still be behind the frame if there was not a bead of weld right there....:banghead:
 

·
Registered
Joined
·
1,271 Posts
man thats sketchy. id be nervous that some metal bits got in the motor. Id ask for a new one from trask....
 
1 - 16 of 16 Posts
Top