Harley Davidson V-Rod Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
601 Posts
Discussion Starter #1
Ok I just found this forum, was hang out over at the (HarleyDavidsonForum) now the V-Twin Forum and I see a lot of the regulars from there have made it over here and you can now add me to the list.

As for myself I live in Northern VA and have had my V-Rod since May 02. I have over 7000 miles on it and one of the best ride I have been on was a pick up ride to the eastern shore of MD up to Mike's famous (oh yes he is over price but he has it for those that have to have it now) in New Castle DE, then down route 9 to Dover to 301 and home. All in one day, it was a great ride, we did it on a Friday and traffic was light and roads were fantastic.

I am a member of Fairfax HOG and enjoy the rides they put together. I am planning on going on another pick up ride to Cumberland MD, just to do some leaf peeping, mid October. Again it a during the week ride.

As for my ride I love my V-Rod have not had a problem, H-D really hit a homer with this one, too bad some have closed minds, but that is another story. Anyway Hi everybody glad to find another great place for V-Rod owners.

Thanks,

Dave

P.S. Just let me know where you'd like to send my pics and I too will share my ride with you folks in your gallery
 

·
Color me Gone
Joined
·
27,333 Posts
Welcome Dave

Glad to have you here with us. To get your bike in the members gallery send those pics to [email protected] and I will get them in tonight.

Max
 

·
If You Ain't Cav...
Joined
·
2,069 Posts
Dave,
Welcome! I'm just up the road a bit, on the other side of Baltimore. Bel Air, closest big town, is about 3-4 miles south from me in here in Forest Hill. If you are ever headed up this way, PM me and I will (work allowing) hit the open road with you. Or if your ever in an emergency and need a place to lay low! LOL!

Mike
 

·
Registered
Joined
·
601 Posts
Discussion Starter #4
HI Max thanks for the post on the V-Twin Forum re engine light

Hi Max, THANK!!! I used your post on the V-Twin forum, to try to see if I had any error codes showing up on my V-Rod. My check engine light stays on a little bit once I start her up and I used your description as to how to check it. Not sure what it was because under all 3 area it came back none, looks like if I read it correctly it maybe the battery, so I am going to check it that this evening. But if the battery is good I am not going to worry about it. Could be that it just doesn't like to start in cold weather, been riding it to work the last couple of days and this morning the low in our area was 30 degrees. I think, I am going to have to find my chaps, Dockers aren't doing the trick.

Thanks,

Dave
 

·
Registered
Joined
·
601 Posts
Discussion Starter #6
Hay BikerTrash1130,

Yes I made it over looks like a real good forum, thanks for letting me know about it.

Dave
 

·
Color me Gone
Joined
·
27,333 Posts
Well Dave I got your pictures and your now in the official members gallery. And you have five post so you can change your rank title to whatever you like.

Max
 
1 - 7 of 7 Posts
Top