Harley Davidson V-Rod Forum banner
1 - 11 of 11 Posts

·
Fireman/investigator
Joined
·
1,965 Posts
I brought this to the attention of the local dealer wrench, who was talking with another guy about an intermittent no-start of another v-rod. You could almost see the little light bulb go on when I told him. Let us know if that is your problem, jambimmer. Sure sounds like it to me.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
you guys are so helpful. I dont know what to do without this forum. I was going to jumpstart my bike when I decided to look at loose connection in the solenoid which was posted here by somebody. The wire in the solenoid was loose. It starts now. But i a have concern about the engine light coming on for about 5 seconds then comes off. Any idea?
 

·
Color me Gone
Joined
·
27,333 Posts
jambimmer that is normal to get an engine light for 5-8 seconds after startup. It seems to be a false ghost code most of the time or it could be a code in history. If there is a current failure the light will stay on.

Max
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #11 ·
max thanks for the replying quickly. when I swithc the kill switch to on the engine light comes on like it normally does then comes off. but after 3 seconds it goes on again for 5 seconds then it goes off. this happens even if the engine is not running. just making sure it is safe to ride it.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top