Harley Davidson V-Rod Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I change the two front turn signal on my muscle and now they don,t work anymore .The turn signal box for the led turn signal receive power but doesn't have any out put ,is it possible that due to a short in my turn signal it toasted my turn signal box
 

·
Dare to Dream
Joined
·
497 Posts
Yes, however you may want to pop the cover off the LED signal box to see if it is fuse protected internally, thats if you didnt just blow a fuse box fuse. Also im not certain what you were doing exactly, changing signals, just removing the mirrors for work being done, but if you were changing signals altogether the LED box may not work with incandescent bulbs, you may have to use the wiring going to the flash box, not from it for your signal power if possible. I do not own a muscle, but I have alot of experience with those mirrors and LEDs in general.
 

·
durata membro
Joined
·
17,603 Posts
Check all the fuses.Check for power at the positive and negative wires to make sure the polarity is not switched.Quit a few V-Rods come from the factory w the polarity reversed.An LED is a diode and polarity sensitive.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
led problem

yes it s a vrod muscle and I change both turn signal because the bike went in a crash and the mirroir were ripped of so the wired were cut and it s possible that the wire short together .. and that why , i think that my control box don'T work ,I got pusle from the harness but not fromm the out put of the box...any trick to fix that box who cost 300$ can
 

·
durata membro
Joined
·
17,603 Posts
Magicians,dogs and hookers do tricks,not motorcycle mechanics.:)
If you are sure the module is the problem,then look for a used module on this forum and ebay.
 

·
2" of dangling death
Joined
·
10,933 Posts
Make sure you have them wired correctly in the plug, should go black, purple, blue, blue, purple, black
 
1 - 6 of 6 Posts
Top