Harley Davidson V-Rod Forum banner

1 - 4 of 4 Posts

·
Dj, Vrodder
Joined
·
182 Posts
Discussion Starter · #1 ·
Okay so last night got my Vmod style cut done and installed my power commander and went topless. Decent running today but seemed like it stumbled between 5-6k, however that seems to come and go, gonna try another map maybe. (am mentioning this to let you know what happened up to the point of the leak) Went for a 60 some mile ride today and then noticed some orange coolant on the frame. Looked as best as I could and seems like its coming from the cap on the bottle right next to the battery. I am going to check my clamps like Ski said in 101 but wanted to ask if this could be in any way shape or form be caused by the bike not running right cause of the PC and Pipe change?
Any thoughts are appreciated! By the Way 03 A model.
 

·
Color me Gone
Joined
·
27,333 Posts
Make sure while you were working that you didn't crack the plastic on the cap. You show to have an 03 and the original 03 caps were bad about it.
 

·
Registered
Joined
·
172 Posts
Just had a similar problem with mine. The downtube off the plastic cap broke off. No return so the coolant bottle was just filling up and overflowing.

If that's it, easy fix. You have to replace the coolant overflow bottle with the new version. 15min and done! Hard thing is finding a stealer with one in stock.

Hope you're fix is as easy as mine was.
 

·
Dj, Vrodder
Joined
·
182 Posts
Discussion Starter · #4 ·
Thanks guys, I could have dug more I suppose before asking, I should know better. Seems to be the problem. Thanks again!
 
1 - 4 of 4 Posts
Top