Harley Davidson V-Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 2004 Vrod ran great last week when I parked it. Started it up this week and it won't run other than at idle. Reving causes backfires, and stalls out. Can not make enough power to ride. Had no issue before this. Something happened while it was parked for a week??? Changed plugs, but nothing changed. Any ideas are appreciated.

Thanks, Eric
 

·
Registered
Joined
·
658 Posts
without other details I would check fuel system first, as in is there enough, and then fuel pressure.
 

·
Registered
Joined
·
5,229 Posts
Do you have any codes showing? Could be several things. Make sure the fuel isn't bad and pump pressure is normal. I'd do a voltage sweep of the TPS sensor and rule that out. Back probe the signal wire and use a VOM. Idle position, it should read anywhere between 0.43 - 0.47 and full throttle it should read about 4.3+. There should be no jumps in the voltage readings turning the throttle slowly to full open.
Ron
 

·
Registered
Joined
·
1,012 Posts
Early models had issues with coils. Make sure the center spring is stretched out enough to make contact with the coil and spark plug. Find which cyinder is the problem and swap coils from front to rear, and see if the problem changes cylinders.
 

·
Registered
Joined
·
2 Posts
Different bike.. But this happened to my other bike... An 03 Softail.. Same.. And I mean exact same thing outta no where on 95 South no less.. Scary.. Anyway it was my fuel pump.. Or more precise the Regulator.
 
1 - 5 of 5 Posts
Top