Harley Davidson V-Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I recently purchased a used heavycycles stage 1 tail light from one of our fellow v-rodders. I got a good price so I am not overly concerned, but the light does not display the "V". I was rather disappointed to see that it didn't. It's plug and play so I can not imagine what would cause this to not work properly. Is it possible they had an older version of the light that did not have that design? I know it is just a matter of how the led's are wired to get the effect, but not sure if I did something wrong. Anyone happen to know what I am missing? I appreciate the insight!!
 

·
K.I.A. '07 AW
Joined
·
10,908 Posts
not all of the HC tail lights are the V light.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
Agreed...still pleased with the light. Beats the hell out of the $4 spinning light bulb I had before. LOL. Man that was cheesy. There has to be a way to wire it to create the effect, just not sure what it would take or whether it is within the ability of the electrically challenged....or just impossible due to the complexity of how the leds are strung together. Where there is a will, there's a way..right?
 

·
K.I.A. '07 AW
Joined
·
10,908 Posts
you could send an email to heavycycles.com and see what Joe would charge you to convert it to a 'V'.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top