Harley Davidson V-Rod Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
964 Posts
Discussion Starter · #1 ·
I traded my bike last weekend which has a daytona VRFID installed on it. Keep in mind I rode the bike to the dealer and they RODE the bike from teh front parking lot to the rear service lot. I also had 3000 miles on teh bike since I installed the VRFID with little to no problems (once I found the leak in the weld)

I went on my way with my new bike. I was hanging out at my local tatoo parlor last night when the guy that owns it said "man those guys at the harley shop are cussing you" When I inquired as to why, he told me the bike wont run and has the check engine light on all the time.

He happened to know the tech that was working on it so we called him trying to help him get it corrected.

After a brief conversation I determined that he had started it by holding open the throttle a ways when he hit the run switch which has caused it to not zero correctly. Then when he had stumbles in the engine he promptly REMOVED the O2 sensors.

I figure thats why its having the check engine light on it and told him it will not run with only the stock map and will not adjust at all.

I offered to come over with the instructions and help him go over it to see what may have happened but he just wanted the stock ecm back and was going to put a SE flash on it regardless of the d and d pipe.

I would have expected more from a person trianed a lot more than I on working on bikes.
 

·
Registered
Joined
·
5,869 Posts
Minimally, the tech should've known not to touch the throttle on an EFI bike when starting. That's not unique to the VRFI-D. And to then pull the O2 sensors??? What a knucklehead!!!

This can be to your benefit - give them back the stock ECM and then pull the VRFI-D to sell here. Sounds like that tech will probably just pitch it anyway.
 

·
Registered
Joined
·
964 Posts
Discussion Starter · #3 ·
lol thats a good idea.
 

·
Registered
Joined
·
323 Posts
vrfi

Yeah, I too would be interested if you can get it back.
Rondo
 

·
Registered
Joined
·
964 Posts
Discussion Starter · #7 ·
They gave it back to me. I didnt even ask them. I went in, offered to help them get it back together and they said no thanks, here take this and give us your ecm.

I did and smiled and walked away.

it was Cole's Hd

o2 man if you want it its yours you have been such a help to me in the past...pm me and lets work out the details.
 

·
Premium Member
Joined
·
7,727 Posts
vesteroid said:
They gave it back to me. I didnt even ask them. I went in, offered to help them get it back together and they said no thanks, here take this and give us your ecm.

I did and smiled and walked away.

it was Cole's Hd

o2 man if you want it its yours you have been such a help to me in the past...pm me and lets work out the details.
Thanks again Bud. I cannot tell you how much I appreciate this. I cannot wait to be able to use this with my 1350 build. I hope I can figure it out, if the dealer could not what are the chances I can? hehehe :angeldev:
 

·
Registered
Joined
·
964 Posts
Discussion Starter · #10 ·
Its not hard at all to physicaly put it on the bike. Getting the welding done correctly is a bit tough.

I had two different guys weld two different pipes and neither did a good job. I finally took it to a tig welder and he found the leak with some dye he had and fixed it right for me.

The tuning part is a bit tricky. I always wondered if I had a bad IAC. I had a difficult time getting the voltage down below .7 I could get it there but never much below.

I can tell you there is a stark difference in power between my dx and my se (dx has less). Of course the turbo should help with that lol.
 
1 - 10 of 10 Posts
Top