Harley Davidson V-Rod Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
About a year and a half ago I installed the HD Mini-Bullet LED turn signal kit (68863-08). Ever since the the error code for right-rear turn signal would come on every so often. I always thought it was just a connection rattling loose as I would take things apart, reseat the connection, clear the code, and all would be well for a little bit. But after a year and a half of the issue periodically coming back I finally said screw it and took teh bike to the shop. They replaced the control module and the issue still happened, the only thing they have found to fix it is to install a load balancer (which shouldn't be needed). So on Tuesday they are going to call harley and try to figure out whats going on. Anybody else had this issue? Faulty modules in general or something?
 

·
Premium Member
Joined
·
319 Posts
What year bike is it? If bike came stock with incandescent bulbs it will need a load equalizer. If it came stock with leds...you should not need one.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
Bike is a 2004 and LED's do not come standard with it. I've replaced the tail light with a HeavyCycles LED light (no issues there) and the turn signals with HD brand LED lights. According to Harley they don't require a load balancer, that should be built into the control box I would think. At any rate they will be called to find out why one is being required to keep the error from being triggered.
 

·
Registered
Joined
·
600 Posts
From what I have been told if you install just front or just rear LED turn signal you should not need a load balancer however if you install both front and rear LED turn signals you must install a load balancer. You may want to check what a supplier like Custom Dynamics says on their website about this issue.
 
1 - 4 of 4 Posts
Top