Harley Davidson V-Rod Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
503 Posts
Discussion Starter #1
Hello all... I've never been able to get the fork lock on my 02 to work... it seems jammed... I put the key in.. but no amount of wiggling or moving the fork back and forth a little bit seems to work. The lock does not even begin to move... it's not an issue with the shaft not engageing the fork..

many thanks
 

·
On Good Ol' Nbr7
Joined
·
7,267 Posts
OK, this may be a dumb question but which way are you turning the key once you have it inserted into the lock?

Clockwise (toward the front tire) or counter-clockwise (to the rear)?

Does it turn at all?

HoldHard
 

·
Registered
Joined
·
503 Posts
Discussion Starter #4
THANK YOU VERY MUCH GUYS... 2 quick squirts of wd40///wait three seconds.. give it a turn... and that old miwaukee pot metal they used just slips n slides...

many, many thanks

greg
 

·
Moderator
Joined
·
4,638 Posts
gthong said:
THANK YOU VERY MUCH GUYS... 2 quick squirts of wd40///wait three seconds.. give it a turn... and that old miwaukee pot metal they used just slips n slides...many, many thanks

greg
We might want to move this to the Mens Lounge.... :rofl2: :rofl2: :rofl2:
 

·
Greg/Moderator
Joined
·
18,951 Posts
Wd 40 is good for working something loose but,put a good oil on it in a couple of days and every so often as prevented maintains.
 

·
Registered
Joined
·
349 Posts
at first mine didn't want to work either. What I learned is that you have to keep pushing in on the key while turning clockwise to lock. Never let up on the pressure while you lock and unlock the fork... I never did use any WD40... but I'm sure that has to help out as well. But I think mine not working was user error on my part...
 
1 - 7 of 7 Posts
Top