Harley Davidson V-Rod Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi Folks. My 2003 VROD has been running flawlessly for the past year. 8 months ago I installed the Vance & Hines exhaust, PowerCommander III, and a K&N filter. Nice sound, runs strong. Since then, everything runs great. I keep the battery charged regularly.

But yesterday and today my VROD experienced difficulty starting. It used to fire right up, no delay. But now I have to hold the start button forever, or try it 3-8 times. The engine turns over fine, but doesn't fire up. No battery problems. It's almost as if there's no fuel. It feels like my carbureted bikes do when I don't pull the choke and twist the throttle a few times. It just cranks and cranks and cranks.

What should I look for? Is anyone else experiencing hard starting like this? Is there any known starting problem? Thanks in advance...

Lance
 

·
Diesel Smoke Tester
Joined
·
862 Posts
Time for the "fix"

My '03 did the same exact thing last month: After installing the upgraded fuel line nipple in the fuel flange module....all is very well! My bike was not on the dealer's list of recalled VIN numbers either. But I know a fuel pressure problem when I see it...and that was it. Your fuel pump is picking up the fuel and pumping it through the pump; but the loose fitting that goes into the fuel flange on top of your tank is letting it all leak and spray back into the tank instead of sending it to the throttle body, and then the injectors. You can see this problem if you look into your gas tank when the engine is running at an idle. If you see a bunch of fuel spraying around in there...that's the it.
Just pull out the loose fitting and replace it with a $1.50 brass push-on nipple with 1/8' pipe threads. Use a good stainless hose clamp...and your on your way. Hope this works. Pretty sure it will. good luck redrazor :cheers:
 
1 - 3 of 3 Posts
Top