Harley Davidson V-Rod Forum banner
1 - 6 of 6 Posts

·
Vrodder since 2004
Joined
·
4,514 Posts
Discussion Starter · #1 ·
At 10,000 I don't really have any serious issues. I plan on getting the fluids changed, the plugs, have them tighten and torque everything . Check the brakes. I do have a small issue with the clutch if anyone knows why it would be appreciated - shifting from 1st to 2nd is difficult- sticks in 1st and alot of times goes right into neutral- I have to really give it a good shove and it sounds aweful. Hopefully some new fluid will help this? If not, any suggestions? Also, lately alot of back pressure in deceleration...pop, pop, pop...its pretty loud. I have Vmodded pipes with a power commander. The pipes also seem to be emitting more heat than usual around the mid area. It gets so hot my butt starts burning.....any suggestions on that one? It was never like that until the last 8 months or so. In the winter, it was flaming hot too. There is no indication of any leaks. Anyway, advice, suggestions, are appreciated! I'd like to go in with some idea of what might be going on.Thanks!
 

·
Premium Member
Pan American Son of VROD :-)
Joined
·
1,093 Posts
Clutch.. Try shifting at higher RPMs and see if it's different. Mine greatly improves over 5Krpm.

Check your settings on the PC... it sounds like adjustment may be in order.
 

·
Scott
Joined
·
492 Posts
violet said:
I do have a small issue with the clutch if anyone knows why it would be appreciated - shifting from 1st to 2nd is difficult- sticks in 1st and alot of times goes right into neutral- I have to really give it a good shove and it sounds aweful. Hopefully some new fluid will help this? If not, any suggestions?

There's a Thread somewhere here about disassembling the shift rod, cleaning it and re-lubercating it which appartently really helped that V-rodder.

Anyone know where this thread is?
 

·
Sanctimonious
Joined
·
44,118 Posts
violet said:
At 10,000 I don't really have any serious issues. I plan on getting the fluids changed, the plugs, have them tighten and torque everything . Check the brakes. I do have a small issue with the clutch if anyone knows why it would be appreciated - shifting from 1st to 2nd is difficult- sticks in 1st and alot of times goes right into neutral- I have to really give it a good shove and it sounds aweful.
Should get better after an oil change, If not than the Rod might need cleaning

violet said:
Also, lately alot of back pressure in deceleration...pop, pop, pop...its pretty loud. I have Vmodded pipes with a power commander.
I believe your running a bit rich
violet said:
The pipes also seem to be emitting more heat than usual around the mid area. It gets so hot my butt starts burning.....any suggestions on that one? It was never like that until the last 8 months or so. In the winter, it was flaming hot too. There is no indication of any leaks. Anyway, advice, suggestions, are appreciated! I'd like to go in with some idea of what might be going on.Thanks!
Its Summer and you live in Temecula:hidesbeh:
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top