Harley Davidson V-Rod Forum banner

61 - 80 of 145 Posts

·
VRSCD
Joined
·
1,012 Posts
:popcorn
 

·
Muscle
Joined
·
208 Posts
Got mine replaced today. Was expecting to see some type of residue on the original tube. The thing looked brand new. Not sure why it started malfunctioning. We'll see if the new sending unit fixes the problem.


Sent from Motorcycle.com Free App
 

·
Premium Member
Joined
·
1,095 Posts
Its not a dirty or gummy condition that's the problem. Its a bad design.
 

·
Registered
Joined
·
232 Posts
Easy install endlink?
 

·
Premium Member
Joined
·
1,095 Posts
Endlink, did your new part have the float like in the pictures earlier in this post? That was the fix to the failed design, an actual float that the sonic sender can bounce the signal off of instead of the surface of the fuel.
 

·
Muscle
Joined
·
208 Posts
Endlink, did your new part have the float like in the pictures earlier in this post? That was the fix to the failed design, an actual float that the sonic sender can bounce the signal off of instead of the surface of the fuel.

Correct. I don't understand how the sonic sender worked for 6,000 bouncing the signal off liquid then all of a sudden it doesn't work. With no evidence to show why it stopped working.


Sent from Motorcycle.com Free App
 

·
Premium Member
Joined
·
1,095 Posts
Yeah me neither but then I' not fully versed on the technology. I've never seen an explanation that fully explains exactly how it works. I understand the concept- just like a depth sounder in a boat works by bouncing a sound wave off a surface. I'm just not sure exactly how HD's unit "sees" the returning signal- that's probably proprietary info. I have however seen the same problem discussed in boating discussion boards, which seems to be another application where these units are used. This tech was supposed to be best used in tanks with irregular shapes because they can be programed to compensate for the shape. That's pretty much what I read about them before losing interest anyway. I just want mine to work.
 

·
Registered
Joined
·
232 Posts
Just ordered mine. Is the replacement procedure found in the service manual?
 

·
Muscle
Joined
·
208 Posts
Just ordered mine. Is the replacement procedure found in the service manual?

Yes. It's simple. Pull main 40a fuse. disconnect all plugs and fittings on the tank. Remove 6 bolts holding tank in place. Remove c clamp from sonic tube on underside of tank cover then pull the tube up through the tank cover. Replace with new sonic tube and reverse instructions. I believe the bolts get torqued to 45-50 in/lbs.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
232 Posts
Thanks!
 

·
Registered
Joined
·
53 Posts
Thank you all for your insight and direction on this fix, I just completed installing a new fuel sending unit in my 2011 Muscle and my fuel gauge is now functioning properly. I also took a video of the entire process and uploaded to Youtube.

From start to finish, took about an hour and the total cost for the unit and o-ring was $85.00. Just a tip, buy the o-ring. I didn't and had to make another trip to the dealer. The original o-ring was stretched and could not be reused, here's the link:

http://youtu.be/JhHUDi5_5q0
 

·
Registered
Joined
·
232 Posts
Happen to have o ring part number?
 

·
Premium Member
Joined
·
1,095 Posts
sorry if this has been covered. Is this the same part number you would order for a 07? Ronnies lists a different number.


Sent from Motorcycle.com Free App
I see it lists a 75210-07 for the '07's and the part that's specified in this thread is 75210-09a which can't be found so we order the 75210-09 and it has the new float in it. I checked 2 dealers, Kutter and Surdyke, and the 75210-07 isn't available either so I believe it's been superceded by the 75210-09 which is actually the 75210-09a....I believe you need the 75210-09.
 
61 - 80 of 145 Posts
Top