Harley Davidson V-Rod Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi guys, got a problem with my DX'13. While was driving in highway got I loss the power and the bike stall. After quick check I've got P0132,P0152 codes and code related to VSS.
So i got my bike to garage and change VSS, now I got P0131, P0151 on idle and if I open the throttle got P0132,P0152...
Fuel injectors working in normal way, removed and checked.
As for manual it said that I should almost check HO2S sensors, but enginge should work normal on idle or it doesn't matter?

Have anyone got any ideas how to solve or where to look the problem?
 

·
Registered
Joined
·
5,238 Posts
Hi guys, got a problem with my DX'13. While was driving in highway got I loss the power and the bike stall. After quick check I've got P0132,P0152 codes and code related to VSS.
So i got my bike to garage and change VSS, now I got P0131, P0151 on idle and if I open the throttle got P0132,P0152...
Fuel injectors working in normal way, removed and checked.
As for manual it said that I should almost check HO2S sensors, but enginge should work normal on idle or it doesn't matter?

Have anyone got any ideas how to solve or where to look the problem?
First off, are you running any piggy back tuner that utilizes the stock O2 sensors?
Ron
 

·
Premium Member
Joined
·
6,248 Posts
...
...While was driving in highway got I loss the power and the bike stall. After quick check I've got P0132,P0152 codes and code related to VSS.
So i got my bike to garage and change VSS, now I got P0131, P0151 on idle and if I open the throttle got P0132,P0152...
Fuel injectors working in normal way, removed and checked.
As for manual it said that I should almost check HO2S sensors, but enginge should work normal on idle or it doesn't matter?

Have anyone got any ideas how to solve or where to look the problem?
The P0131 and P0151 codes mean the engine is running lean.
The P0132 and P0152 codes mean the engine is running rich.

These types of DTCs can be triggered by problems with the fuel delivery, air leaks in the intake/exhaust systems, or problems with the ignition, as well as the normal "bad tune" problems when stock components are replaced with aftermarket items.

Since you claim everything is stock, you either have faulty O2 sensors or problems with ignition, fuel delivery, or air leaks.
 

·
Registered
Joined
·
5,238 Posts
It's almost pointing to faulty O2 sensors. Did you run any non friendly additives in the fuel lately or does your engine use more then normal amount of oil? Still strange how both would crap out and go out of range. Only commonality between them is they share the same ground but the codes don't support a problem with that.
Ron
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
It's almost pointing to faulty O2 sensors. Did you run any non friendly additives in the fuel lately or does your engine use more then normal amount of oil? Still strange how both would crap out and go out of range. Only commonality between them is they share the same ground but the codes don't support a problem with that.
Ron
I'm not sure what is non friendly additives , but yes i added Motul Fuel System Clean Moto... :banghead: How bad it can be?

I checked the wiring twice it is fully ok.

On the week end will check the O2 sensors.

Thanks a lot guys!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
So finally I've changed O2 for the new one... and still no result, but now I'm getting P1352 for the O2 rear, but it is new, and Side stand message on netural gear...
If I get my bike straight and close the side stand message disappear, so I think it is not the sensor of side stand.
My suggestion it is ECM but may be I should check anything different? And if I will buy ECM I need to go to dealer to calibrate it?
 

·
Premium Member
Joined
·
6,248 Posts
So finally I've changed O2 for the new one... and still no result, but now I'm getting P1352 for the O2 rear, but it is new, and Side stand message on netural gear...
If I get my bike straight and close the side stand message disappear, so I think it is not the sensor of side stand.
My suggestion it is ECM but may be I should check anything different? And if I will buy ECM I need to go to dealer to calibrate it?
DTC P1352 has nothing to do with the O2 sensor. That code means your front ignition coil is not working. The voltage measured on the coil signal circuit was high or shorted. This means there's a short to voltage on the BE/O (blue with orange stripe) wire that runs from ECM terminal #29 to the front coil or the ECM is damaged.

If the ECM is damaged the new one will need to be programmed at the dealer.
 
1 - 8 of 8 Posts
Top