Harley Davidson V-Rod Forum banner
1 - 11 of 11 Posts

·
ColonelB
Joined
·
162 Posts
Discussion Starter · #1 · (Edited)
I haven't seen this elsewhere in our forum, so I thought I'd ask if anyone knows how I should proceed with replacing my water pump. I'm about to hit the 80K mile point, and got a leak from this general area. There is a missing piece of engine block where the water pump inner gasket should seal the pump to the block. Looks about 3/8" long and about an eighth of an inch deep.

Sorry for the image malfunction; I haven't posted in awhile. Brain fart over.

The picture of this in the manual don't have this "divot" ......

Thx,
Chris
 

Attachments

·
Registered
Joined
·
5,818 Posts



I haven't seen this elsewhere in our forum, so I thought I'd ask if anyone knows how I should proceed with replacing my water pump. I'm about to hit the 80K mile point, and got a leak from this general area. There is a missing piece of engine block where the water pump inner gasket should seal the pump to the block. Looks about 3/8" long and about an eighth of an inch deep.

Thx,
Chris
Got a good pic of the area in question?
Ron
 

·
Premium Member
Joined
·
11,390 Posts
He posted two links to Shutterfly.com but you need a sign on to view them.
 

·
Registered
Joined
·
2,242 Posts
Thanks for looking! Got the pictures working now.
Yes, they are supposed to be there. When the seal leaks the water passes through that track into the lower chamber and then out through the hole on the left giving a telltale that the seal is leaking. Most auto water pumps also have a hole on the outer side of the seal for this purpose. Looking at the colour of your lower chamber looks like its been leaking for a while.
 

·
ColonelB
Joined
·
162 Posts
Discussion Starter · #9 ·
Unbelievable! I looked at the same picture in my manual and just completely ignored the "missing" piece. I am waiting on the inner seal to arrive as the original is corroded pretty badly on that side. I guess it can seep for a long time without drawing down the reservoir?

Thanks much!
 

·
Registered
Joined
·
5,818 Posts
Unbelievable! I looked at the same picture in my manual and just completely ignored the "missing" piece. I am waiting on the inner seal to arrive as the original is corroded pretty badly on that side. I guess it can seep for a long time without drawing down the reservoir?

Thanks much!
You can also see why pointing a water hose at that weep hole when washing the bike is not a good idea. It will fill the cavity with water and cause the metal gasket to corrode. Antfreeze itself won't do that, just leave the dye color behind when it dries.
Ron
 

·
ColonelB
Joined
·
162 Posts
Discussion Starter · #11 ·
And another great point, thanks Ron!

I think I rode through your town about 3 years ago with a Virginia PGR group that lays a wreath at the Wall in Windsor after laying it at the DC one. Afterwards, a Canadian Legion group led us on a nice ride towards Niagara. I was on a Honda ST1300, on that ride but about as much discomfort I would guess the V-Rod would have given me. Beautiful ride though!

Chris
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top