Harley Davidson V-Rod Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
I have a 2009 VRSCDX and I purchased the Custom Dynamics Light Modulator for Harley V-Rod 2002-2010.

The connectors do not mate up. So my thought on possible culprits are...

1) Wrong device (the label is correct but the item itself is wrong)

2) The VRSCDX specifically does not have the same plug as other V-Rods from 2002-2010.

3) This is an aftermarket plug put on by the PO.

4) This is the wrong plug entirely and I am way off base!

Before I go back to Revzilla about it, I was hoping to find out where the fault lies.

Thanks!
Ryan
 

Attachments

·
VRSC est -03
Joined
·
3,094 Posts
Not shure witch circuit you`re looking for but -
There`s a tail lamp + turn signal connectors located behind the tail lamp / fender. Pull rear seat.
Another turn signal connector is located behind left side tree neck cover.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
Not shure witch circuit you`re looking for but -
There`s a tail lamp + turn signal connectors located behind the tail lamp / fender. Pull rear seat.
Another turn signal connector is located behind left side tree neck cover.
EUREKA! Thank you Knut, it turns out I just jumped the gun here. The directions simply say "under the seat" so I made a snap decision that I had the wrong part.

However, you were correct. The turn signal connector under the rear seat was exactly what I needed. It hooked right in and immediately started working. Very simple design. Couldn't be easier to install. I'm definitely a fan of this item.
 

Attachments

1 - 6 of 6 Posts
Top