Harley Davidson V-Rod Forum banner

161 - 173 of 173 Posts

·
Super Moderator
Joined
·
6,248 Posts
many thanks stever975
is that why it's using more fuel and running shit or is that a seperate issue ?
john
If you do have a short to 12 volts on the serial feed, this could cause a number of problems that would affect how the engine runs. This could also set other DTCs (e.g., P1009 or P1010) or prevent the engine from running at all.
 

·
Registered
Joined
·
72 Posts
thanks stever975 the code seems to be historic maybe the problem is my fuel rail or pump...does the breather pipe have to be connected to the fuel pump ? as it's not connected and hasn't been since i got the bike a few months ago
 

·
Super Moderator
Joined
·
6,248 Posts
thanks stever975 the code seems to be historic maybe the problem is my fuel rail or pump...does the breather pipe have to be connected to the fuel pump ? as it's not connected and hasn't been since i got the bike a few months ago
I'm not following you.

The fuel pump feeds the fuel supply line that exits the fuel tank. This fuel feed line connects to the fuel rail between the throttle bodies. The fuel rail feeds the fuel injectors and the pressure regulator that maintains ≈ 60 psi fuel pressure. The pressure regulator sends the excess fuel back to the tank via a fuel return line. There's no breather pipe associated with the fuel rail or fuel pump. The fuel tank has a vent port that should connect to a "tip-over" valve (2007 and newer models have the tip-over valve incorporated in the fuel flange at the top of the tank).

Are you calling the fuel tank vent line the breather pipe?
 

·
Super Moderator
Joined
·
6,248 Posts
yes im calling it the breather it's on top of the fuel tank next to the fuel feed
sorry if i made it confusing
As long as the fuel tank vent port isn't blocked the vent line not being connected shouldn't cause the engine to run rough. It's a safety issue though since this port can spill fuel (either from over filling the tank or due to splashing while riding the bike) and if not redirected by the vent line to go to the ground you could have a fuel fire.

It's likely this bike needs a through "look-over" by someone familiar with the VRSC bike.
 

·
Registered
Joined
·
72 Posts
best i re connect it then..yes the bike prob could do with a good going over..after about 15 miles or so it struggles to rev past 4k
 

·
Registered
Joined
·
72 Posts
hi all i wonder if any one can explain these codes to me and tell me what i need to do U1255 U1016 and B1005 the bike has started to run like crap and feels like it's running weak..any help will be appreciated

john
 

·
Super Moderator
Joined
·
6,248 Posts
hi all i wonder if any one can explain these codes to me and tell me what i need to do U1255 U1016 and B1005 the bike has started to run like crap and feels like it's running weak..any help will be appreciated

john
With that many DTCs on a bike that's still running, I'd guess a bad ground connection.

First check the battery negative wire. Then check the screws for items 1 and 3, and then the screw for items 8, 9, and 10 shown in this picture:

Then check the engine ground connector to the frame shown here (it runs from the oil sump to the frame cross member):


The B1005 DTC is usually an unplugged fuel sensor or a short to voltage on the Y/W (yellow with white stripe) wire that connects to IM (instrument module) terminal #11 but this shouldn't affect the engine's performance.
 

·
Registered
Joined
·
72 Posts
ill check out the earth wires and see what happens i may disconnect my pc v and check that out as i don't know why it's running weak all of a sudden
john
 

·
Super Moderator
Joined
·
6,248 Posts
ill check out the earth wires and see what happens i may disconnect my pc v and check that out as i don't know why it's running weak all of a sudden
john
You should have mentioned that you were using a PC V in the previous post.

I would have mentioned to check that before the ground wires.
 

·
Registered
Joined
·
72 Posts
well i un plugged the pcv and it was full of water hopefully it'll be ok now after a good dosing of wd 40 if it loses the map in the memory im stuffed as i don't have the map guess ill have to ride it and see
john
 

·
Registered
Joined
·
72 Posts
ill check out the earth wires and see what happens i may disconnect my pc v and check that out as i don't know why it's running weak all of a sudden
john
well i un plugged the pcv and it was full of water in the plug hopefully it'll be ok now after a good dosing of wd 40 if it loses the map in the memory im stuffed as i don't have the map guess ill have to ride it and see
john
 
161 - 173 of 173 Posts
Top