Harley Davidson V-Rod Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,541 Posts
Discussion Starter · #1 ·
I was wondering if you guys with higher milage motors still have a small amount of metal chips on your magnetic drain plug. I assume it's normal for a newer motor. Thanks
 

·
Registered
Joined
·
250 Posts
I've got about 35,000 miles on my bike. Never noticed any metal particles on the drain plug.

I generally change the oil and filter every 2000-2500 miles or so. And while I don't obsess over the drained oil (sniffing it, for instance) - I do usually wipe the drain plug clean before re-inserting it. Never noticed metal chips.

Do you have other symptoms that something may be going on? Weird noises, oil leaks, etc.?

PS: Great title for the thread!
 

·
Blowin' Smoke
Joined
·
2,647 Posts
42,000 here. I change the Amsoil every 5,000 miles. I never see anything on the magnet or in the plug. Each time I drain the oil it sits in the pan for a bit, then I pour it into jugs for the trip to recycle. I never see anything left in the bottom of the pan or the jugs. I use zero oil between changes.
 

·
durata membro
Joined
·
17,603 Posts
DallasV Rod said:
I pour my oil in the kitchen sink! :D
I have a 50ft 4 inch pipe driven at an angle into my neighbors yard that I dump mine into.:)


On the 03 I had a small sliver on the magnet once.Now at sevices I just have a little black dust stuck to the magnet,not much at all,I have over 40k on it.
The 07 has a smaller amount of dust but I've not seen a chip,yet.I have over 10k on this one.



Elrod on the V-Rod
 
1 - 5 of 5 Posts
Top