Harley Davidson V-Rod Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
1,138 Posts
Discussion Starter · #1 ·
Ever since I did my 240 mod, I have had a strange brake noise. The noise only appears at the last instant of stopping. Sounds like cutting a brake rotor without a band. The pads are brand new OEM, I really don't think it's the pads. I have had the wheel off 3 times looking for problem, but cannot find it. I just replaced the rubber peg in the bracket and a new spring clip for pads. This cured problem for most of a 10 mile ride, but the noise is back. Anyone have any ideas, I'm at a lost. Thanks, Skip.
 

·
Color me Gone
Joined
·
27,333 Posts
Some rotors and some pads just make noise together. You might try some of the aftermarket brake pads. My bike had never made any brake noise until I changed brake pads to the new harder OEM pads and now my rear brakes for the first time make noise just as you come to a full stop every now and then. I plan to change the pads to a different brand when I get a chance to see if it cures the problem.
 

·
Will Work For Mod $$
Joined
·
2,866 Posts

·
Premium Member
Joined
·
1,138 Posts
Discussion Starter · #4 ·
Never thought this fix would be this easy. I just installed a aftermarket set of pads (my buddy is a Drag Specialities dealer) that a got for next to nothing. The noise appears to be gone, I'll know better after some more miles. Thanks to Max and Mustang for pointing out the obvious, I was looking way too deep. Thanks again, Skip.
 
1 - 4 of 4 Posts
Top