Harley Davidson V-Rod Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
254 Posts
Discussion Starter · #1 ·
Just went riding tonight, rechecked all my settings... first three are set to 1, the NOS setting I moved up from 6.5 to 7.

When hitting the horn button with no nos, the bike bogs down when idling... but out riding now, at WOT when I hit the horn button with no nos, the bog down is substantially less than it was before... any ideas?

When I turn the juice on and hit the horn button, the nitrous still works... but seems not as powerful before, this seems to confirm that I'm not getting as much extra fuel as I did before...

What can I do to remedy this?
 

·
Registered
Joined
·
254 Posts
Discussion Starter · #3 ·
No you're missing the point, the NOS bottle still has plenty of N20 in it... When its turned OFF, my bike used to bog down more heavily when I hit the horn button because of the extra fuel and no N20 to help burn it off... now it doesnt bog as much, which makes me think its not getting the same amount of fuel added???

When the nitrous is open and flowing, it still accelerates, but seems not as much as when first installed... its like something changed, but all my settings are still the same?
 

·
Sua Sponte
Joined
·
1,560 Posts
I think you are just getting used to it. Quit hittin' that button unless you got a need for speed. If you've hooked everything up properly you shouldnt be having any problems. Like I said, I think you are just getting used to it. Nowadays, 130mph just seems slow to me but when I first sprayed my way up to that speed, I thought my face was melting.
 

·
Registered
Joined
·
25 Posts
Boss Noss

Mark Ducati said:
Just went riding tonight, rechecked all my settings... first three are set to 1, the NOS setting I moved up from 6.5 to 7.

When hitting the horn button with no nos, the bike bogs down when idling... but out riding now, at WOT when I hit the horn button with no nos, the bog down is substantially less than it was before... any ideas?

When I turn the juice on and hit the horn button, the nitrous still works... but seems not as powerful before, this seems to confirm that I'm not getting as much extra fuel as I did before...

What can I do to remedy this?
Hi Mark. If you are still having this problem, it may be that...
-you are desensitised to the power added (getting used to it)
-have a near empty nitrous bottle, or...
-setting the 'hit' to 7 is too rich for your application

You might try the following...
-fill your nitrous bottle (even if you are convinced that it has plenty)
-take a 2-3-4 gear run into the higher rpm's, does it bog/detonate?
-if it 'bogs' or 'cracks' AT ALL in the high rev's, reduce you 'hit' fuel setting by .5. re-run 2-3-4 to high R's. repeat until the first 'clean' run. STOP! you are tuned.
-if it detonates (pops/misses) at ANY lower rpm, STOP! YOU ARE LEAN! start over with your 'hit' fuel set to 8 and re-run 2-3-4 to high R's until the first 'clean' run. you are tuned.

If you have any othe system and/or tuning questions, please feel free to write or call anytime!

Happy spraying!

Randy Schwind, National Sales Manager
BOSS NOSS

317-622-1835

[email protected]
 
1 - 5 of 5 Posts
Top